Articulos en Factura y Pedido

Inicio Foros Foro principal Ayuda Articulos en Factura y Pedido

  • Este debate está vacío.
Viendo 15 entradas - de la 1 a la 15 (de un total de 27)
  • Autor
    Entradas
  • #31038
    Luis Castelat
    Miembro

    Que tal, probando la facturacion cuando vamos a cargar el articulo en el primer item del pedido o factura no aparecen articulos que han sido cargados anteriormente, este proceso lo hacemos con el perfil de Ventas, hemos creado más de un artículo o servicio pero no aparece ninguno en la ventana de busqueda de los mismos. Quisiera saber que conf. se deberia tocar para solucionar esto.

    Saludos!!!

    #33271
    Jorgev
    Miembro

    Hola!
    El problema puede ser que los productos que definiste no tiene precio en las listas de compras y ventas.
    Para esto tenes que registrar los precios. Las alternativas son 2:

    1) Ir a la ventana “Artículos”, elegir el articulo que queres vender, ir la pestaña “Precio” e ingresar los precios. Es conveniente ingresar tanto el venta como el de costo, de manera de poder usar el producto tanto en las operaciones con proveedores como con clientes.

    2) Ir a la ventana “Tarifas”, que es desde donde se mantienen las listas de precios.

    * Para el precio de venta
    Tarifa => Elegir “Ventas”
    Versión=> Elegir “Ventas inicial”
    Precio de producto => Crear los registros de los precios de tus artículos…
    * Para el precio de costo
    Tarifa => Elegir “Costo”
    Versión=> Elegir “Costo inicial”
    Precio de producto => Crear los registros de los precios de tus artículos…

    El sistema valida que los productos ingresados en las facturas y en los pedidos existan en la lista de precios que se selecciona. Esto es, si en la cabecera del pedido indico la lista X, los productos que ingrese en las lineas tienen que tener precio en dicha lista X, sino dará error.

    Saldudos,
    Jorge

    #33272
    Jorgev
    Miembro

    Un mas, te dejo la ventana de artículos con el precio definido.
    Saludos Pantallazo_1.png

    #33273
    Dario Parente
    Miembro

    He colocado los precios como dice en el grafico pero no logro que me aparezcan los articulos.
    Puede ser por alguna razon mas?

    #34691

    Si tampoco te funciona el buscador de Entidades Comerciales, entonces lo mas probable es que tengas mal instalado el pl/java, fijate en el foro que hay muchos hilos que tratan ese tema.

    Ahora, si el único buscador que no te anda es el de artículos, fijate que debes estar filtrando por alguna tarifa cuya versión no tiene artículos cargados. Entra a alguna tarifa y fijate que tiene, es probable que esten vacías.

    #33274
    Dario Parente
    Miembro

    Bueno, paso a explicarme, Probe con libertya 10.03 con localizacion para Argentina, tanto en linux como en windows Xp.
    El Pl/Java esta funcionando porque la busqueda para EC funciona bien, el problema es solo con los articulos.
    Segui las pruebas con WindowsXP, desinstale todo, por las dudas habia un error grave mio, y lo instale de cero.
    Segui un ejemplo que se dio en el curso.
    Primero cargue unas entidades comerciales, despues cree unas familias y subfamilias, despues cargue tres articulos a los cuales les puse los precios de costo inicial y ventas inicial.
    Segui al pie de la letra el ejemplo, porque luego de cargar esto habia que entrar con el perfil de almacenes y cargarles un inventario fisico.
    Entre en inventario fisico grave el documento, genere la lista voy a la pestaña de linea de recuento al campo articulo cuando pongo buscar no me aparece ninguno, y pasa en inventario, pedido, etc, todos los sitios donde se pueda buscar articulos.

    Fui como me dices a ver la tarifa y tanto la de venta inicial, como la de costo inicial en la pestaña de precio de productos aparecen los productos.

    Que puede haber pasado, o es un error de libertia 10.03 localizacion Argentina, y digo localizacion Argentina porque la unica diferencia en los pasos a seguir con el ejemplo que se dio es que el ejemplo se dio con localizacion Internacional.

    Me esta rompiendo la cabeza helpme!!!

    #34703

    Le estas quitando todos los filtros al selector de artículos? que pasa si en vez de ir a buscar un artículo pones el código de búsqueda en el campo Artículo de la línea de la factura?
    Estas trabajando siempre con la misma Organización? Si trabajas con varias organizaciones y dependiendo de la configuración de permisos, solo vas a ver los artículos de una sola organización a la vez.

    #34705

    Una cosa que se me pasó de tu post… el Inventario Físico no te va a capturar los artículos si éstos no tuvieron previamente movimiento de stock, se entiende? solo te los va a capturar si ya existe algún movimiento en ubicaciones de almacén. De manera que eso no es un error, es la forma en que trabaja. Ahora, si no encontras artículos en la factura, algo esta pasando y habría que descartar primero lo que te comenté arriba.

    #33275
    Dario Parente
    Miembro

    Si le he quitado todos los filtros y nada siguen sin aparecer.
    Si en el campo de articulo coloco su clave de busquda me coloca el articulo que tiene dicha clave y me deja seguir con la operatoria, pero ese no es el caso.
    Si en el campo de articulo por ejemplo coloco el nombre directamente me abre la pantalla de seleccion de articulo y no me muestra nada.
    Estoy trabajando con la organizacion por defecto que trae libertya (default) y probe con la * tambien y nada.

    nose que mas hacer.

    #34706

    Según se desprende de tu ultimo Post, el problema que tenes es que , estando por ejemplo en la linea de una factura o cualquier otra ventana que posee un campo “Articulo” usando el código o clave de Búsqueda te lo “trae” a la ventana, en cambio si utilizás la descripción, no lo hace.

    Por otro lado, no lo aclarás, pero seguramente que haciendo click en el botón a la derecha del campo Articulo en la misma ventana e invocando al “Buscador de productos” (o InfoProduct) y completando el campo “descripción” si te muestra el producto.

    Si todo lo anterior es correcto, entonces estás simplemente ante la presencia de un Feature sin implementar: Contrariamente a lo que sucede con las entidades comerciales y algunas otras búsquedas, en la búsqueda que se hace para los productos, solo se busca en el campo código. Para buscar por descripción (asi como por cualquier otro campo) se debe abrir la ventana de búsqueda de productos.

    Esto puede cambiarse modificando un poco el codigo fuente del buscador, sin embargo traería aparejado que las búsquedas de productos tarden mas en bases de datos grandes.

    Es posible que en futuras versiones esto se mejore, pero por ahora es la funcionalidad que posee.

    Espero haber aclarado el tema.

    Saludos
    Antonio.

    #33276
    Dario Parente
    Miembro

    nono ese es el problema, cuando entro a la pantalla de busqueda de articulos no me muestra ninguno, sin a ver pedido que me busque algun articulo.
    A ver si me explico mas graficamente, mi problema es que no veo los articulos en el cuadro de busqueda, sin pedir que me traiga tal o cual articulo poniendo en el campo su clave o descripcion.

    Por ejemplo entro a realizar un pedido ahi esta el campo articulo, (yo se que tengo cargado el articulo con clave 1234), Si hago click en el boton de la derecha del campo articulo, me tendria que mostrar todos los articulos cargados, pues bien no me muestra ninguno, incluso limpiando todos los campos de busquedas, y ya realizado como explico mas arriba las tarifas.
    Si yo en ves de entrar en el cuadro de busqueda de articulos pongo en el campo articulo la clave 1234 me da como que es valido, por lo que no habre el cuadro de busqueda (es logico el articulo colocado existe) y me permite seguir con el pedido o factura o lo que sea.

    Es decir no logro ver ningun articulo si deseo hacerlo con el cuadro de busqueda de articulos.
    Nose si me falta hacer algun paso aparte de las tarifas para poder ver los articulos, como por ejemplo me pasaba con las entidades que no las veia y era porque no habia ingresado su localizacion.
    Eso ya lo resolvi me falta solo poder ver los articulos cargados en la confeccion de facturas o pedidos, etc.

    #34718

    Bien, ahora nos vamos entendiendo.
    La 1era respuesta a este problema es: el PLJava no esta correctamente configurado en tu base de datos.

    Mas arriba en este post, alguien decia que como veias la ventana de busqueda de Entidades comerciales, debia estar funcionando, pero no me queda tan claro que esa ventana haga uso de funciones PLJava.

    Lo que deberias hacer es verificar si tienes el PLJava fucnional. Para eso:
    1) verifica el log de errores cuando abres la ventana de info de productos. Eso lo ves desde el menu en herramientas. Si hay un error “falta un parametro requerido” o algo similar hay 99% de posibiliades de que tu PLJava no este bien.

    2) algo mucho mas concluyente: Con el PGAdmin, te conectas a la base, buscas una funcion cualquiera dentro del esquema Libertya , verificas sus parametros (intentalo con una que solo tenga parametros numericos, como IDs) y luego haces un “select funcion(0,0,0) from ad_user” lo que importa es el nombre de la funcion y la cantidad de ceros que le pongas como parametros (el from es lo mismo cualqueir tabla, solo debe existir). Alli , si el PLJava no esta bien, te va a dar el mensaje de error (por favor anotalo y postealo en el foro). Si esta OK, te va a decir : “0 Rows” , pero no error…. y entonces sabremos que NO es eso.

    Verifica esas dos cosas… pero es casi seguro que no te funciona bien el PLJava.

    Saludos
    Antonio

    #33277
    Dario Parente
    Miembro

    Bueno cuando voy a la busqueda de productos despues de selecionar el boton desde el campo articulos nome tira ningun error.

    Con el pgadmin hago la siguiente consulta nose si estara bien ya que no soy novato postgres.

    select invoicepaid(0,0,0) from ad_user

    ejecuto la consulta y me da como resultado lo siguiente.

    ERROR: stack depth limit exceeded
    HINT: Increase the configuration parameter “max_stack_depth”, after ensuring the platform’s stack depth limit is adequate.
    CONTEXT: PL/pgSQL function “id” line 4 at assignment
    PL/pgSQL function “invoicepaid” line 2 at RETURN
    PL/pgSQL function “invoicepaid” line 2 at RETURN
    PL/pgSQL function “invoicepaid” line 2 at RETURN
    PL/pgSQL function “invoicepaid” line 2 at RETURN
    PL/pgSQL function “invoicepaid” line 2 at RETURN
    PL/pgSQL function “invoicepaid” line 2 at RETURN
    PL/pgSQL function “invoicepaid” line 2 at RETURN
    PL/pgSQL function “invoicepaid” line 2 at RETURN
    PL/pgSQL function “invoicepaid” line 2 at RETURN
    PL/pgSQL function “invoicepaid” line 2 at RETURN

    Eso es lo que realice, por otro lado PL/Java cuando se hace la instalacion en XP en forma automatica no se instala y configura solo?

    gracias

    #33278
    Dario Parente
    Miembro

    A forma de referencia lo anterior lo chequee en una instalacion de linux.

    Viendo una instalacion en XP que tambien tengo y entrando con el pgadmin veo que en la base de datos en la pestaña lenguajes figuran instalados 3.

    java
    javau
    plpgsql

    POr lo que si estaria instalado el pl/java, o no?

    gracias

    #33279
    Dario Parente
    Miembro

    Un error que me da y siempre es el mismo entrando en la pantalla de busqueda de articulo y refrescandola lo cual igual no me muestra nada.
    Al volver de esa pantalla y ver los errores en herramientas-preferencia me pone esto.



    > Msg.getMsg: NOT found: OXPSYS [11]


    > Msg.getMsg: NOT found: OXPSYS [11]


    > Msg.getMsg: NOT found: OXPSYS [11]


    > Msg.getMsg: NOT found: OXPSYS [11]
    ===========> InfoProduct.run: SELECT DISTINCT(p.M_Product_ID), p.Value, p.Name, bomQtyAvailable(p.M_Product_ID,?,0) AS QtyAvailable, bomPriceList(p.M_Product_ID, pr.M_PriceList_Version_ID) AS PriceList, bomPriceStd(p.M_Product_ID, pr.M_PriceList_Version_ID) AS PriceStd, bomQtyOnHand(p.M_Product_ID,?,0) AS QtyOnHand, bomQtyReserved(p.M_Product_ID,?,0) AS QtyReserved, bomQtyOrdered(p.M_Product_ID,?,0) AS QtyOrdered FROM M_Product p LEFT OUTER JOIN M_ProductPrice pr ON (p.M_Product_ID=pr.M_Product_ID AND pr.IsActive=’Y’) LEFT OUTER JOIN M_AttributeSet pa ON (p.M_AttributeSet_ID=pa.M_AttributeSet_ID) WHERE p.IsActive=’Y’ AND p.IsSummary=’N’ AND pr.M_PriceList_Version_ID=? AND p.AD_Client_ID IN(0,1010016) AND p.AD_Org_ID IN(0,1010053) ORDER BY QtyAvailable ASC [410]
    org.postgresql.util.PSQLException: No se ha especificado un valor para el parámetro 1.; State=22023; ErrorCode=0

    at org.postgresql.core.v3.SimpleParameterList.checkAllParametersSet(SimpleParameterList.java:134)
    at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:179)
    at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:437)
    at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:353)
    at org.postgresql.jdbc2.AbstractJdbc2Statement.executeQuery(AbstractJdbc2Statement.java:257)
    at sun.reflect.GeneratedMethodAccessor9.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.postgresql.ds.common.PooledConnectionImpl$StatementHandler.invoke(PooledConnectionImpl.java:467)
    at $Proxy1.executeQuery(Unknown Source)
    at org.openXpertya.util.CPreparedStatement.executeQuery(CPreparedStatement.java:187)
    at org.openXpertya.apps.search.Info$Worker.run(Info.java:1269)

    Servidor = Server1 : 1099 (15-03-2010)
    Tunnel=false, Objects=false, Process=false
    Base de datos = server1 : 5432 / libertya
    Esquema = libertya
    Usuario = AdminLibertya
    Perfil = Compras

Viendo 15 entradas - de la 1 a la 15 (de un total de 27)
  • Debes estar registrado para responder a este debate.