Sigo con problemas de Importacions!!!!!!!!!!!!!!!

Inicio Foros Foro principal Desarrolladores Sigo con problemas de Importacions!!!!!!!!!!!!!!!

  • Este debate está vacío.
Viendo 10 entradas - de la 1 a la 10 (de un total de 10)
  • Autor
    Entradas
  • #31397

    Gente, les comento un poquito.
    Estoy tratando de importar EC y me da error.
    no se que puede ser les envio las imagenes…
    aunque priemro le envio el archivo…

    #34491

    Ahora si el archivo imagen_ec.jpg

    #34495

    importacion.jpg Lo que hago es:
    Me logueo como administrador de sistema
    voy a la ventana cargar archivos
    Selecciono el archivo a cargar
    Voy a formanto de importacion
    elijo: importacion de entidades comerciales
    clicqueo en la flecha derecha
    y queda como sigue

    #34496

    Me queda entonces el siguiente aviso: importar2.jpg

    #34497

    despues no puedo seguir el proceso de importacion.
    Cualquier informacion que puedan brindarme seguramente sera util

    Saludos a todos

    cintia

    #34492
    Javier Ader
    Participante

    Más allá de las imagenes son medio pequeñas no me pareció ver ningún error… Tenés que ir a la ventana de importación especifica de ECs (Importar Entidades Comerciales, si mal no recuerdo) y completar la importación (la importación es un proceso de dos pasos). En esta ventana te va a mostrar la ECs “listas” para importar; desde está ventana es desde donde realmente afectas a las entidades comerciales en el sistema (y lo que te muestra esta ventana es en realidad el producto de los “Cargar Archivos” anteriores).

    #34499

    Gente, bueno, despues mucho intento, hicimos lo que debiamos hacer del “principio”, mirar y leer lo que solicita el sistema.
    El problema que teniamos, en principio, es que el formato de importacion no se respetaba en el csv.
    Entonces, al denotar esto, modificamos el formato de importacion y lo configuramos a nuestro parecer…
    Eliminamos campos, y cambiamos segun nos convenia.
    La cuestion que ahora, si podemos cargar el archivo para importar, pero (como siempre nos falta 1 para el peso), no logramos importar…

    Cuando vamos a la ventana importar entidades comerciales, logramos ver los registros que tragimos del csv pero al invocar el proceso importar nos muestra la siguiente pantalla…

    POr favor cualquier info que me puedan dar sera muy agradecida….
    Saludos importacion3a.jpg

    #34493
    Javier Ader
    Participante

    mmm me parece que estas intentando reimportar cosas que ya fueron importadas antes. En el screenshot que pones,justo la entidad que se muestra tiene el tilde “Importar” que creo que no tiene un nombre muy conveniente ya que el tilde significa que ya fue importado (debería ser llamado “Importado”); lo que tiene el tilde simplemente no se van a importar hagas lo que hagas. Verifica de los cerca de 400 registros para importar que tenes ahi cuales tiene el tilde Importar; me parece que todos lo van a tener….
    Igual, hace esto: ejecuta de nuevo el proceso de Importación (no desde Cargar Archivos, si no desde Importar Entidades Comerciales) y elegí la opción “eliminar importaciones anteriores” (esta opción justamente lo que hace es eliminar las campor en la tabla temporal que estan marcados como “ya importados”; dicho sea de paso, esta opción aunque mete un poco de miedo es segura; usala siempre que puedas para que no te ante mostrando importaciones anteriores). Despues de esto, la ventana de Importación, según mi hipotesis, no te debería mostrar ningún registro. Si es asi, ahora si anda a cargar Archivos y repetis la carga del cvs…. despues de esto, deberías tenes todos los nuevos registros a importar en Importar Entidades comerciales (el Importar debería estar destildado para todos ya que todavía no fueron importados)

    PD : no se como abras modificado el formato de importación… pero NO deberías especificar campo relacionado con el tilde Importar (ese campo es usado internamente solamente para evitar reimpotar cosas viejas; y no esta pensado para que lo setees desde el CVS)

    #34503

    Mejor todavia que lo que propone javier es hacer un truncate Table de la I_BPArtner antes de cargar.
    Por otro lado, antes de importar, entra en el registro de errores, limpialo y miralo luego de importar (si es que sigue fallando) postea eso (hay un boton para guardar el log en un archivo de texto) que ahi seguro está saliendo una excepcion.

    Saludos
    Antonio.

    #34494

    Lo que hicimos……
    Como para que no queden dudas de que habia borrado todo, desintale todo lo que tenga que ver con el sistema, borre la carpeta de postrgres y servidor oxp, tambien elimine los usuarios postgres.
    Los Logs tambien.
    Instale nuevamente Libertya.
    Cuando estaba listo para usar, controle la tabla i_bpartner que este vacia.
    Entonces configure miformato de archivo solo con el nombre y el value.
    Hasta ahi todo ok, pude cargar el archivo.
    Cuando voya a importar sucede lo que antes; ejecuto el proceso y me aparece la ventana que adjunte antes con todos valores en 0. (0 importacion, 0 actualizacion, etc).
    Pero de todas formas coloca el tilde de importar, pero solo en el primer registro.

    La verdad seguimos en el asunto…..

    Probamos importar las cuentas contables, salio todo como por un tubo (con el archivo que trae Libertya para importar).

Viendo 10 entradas - de la 1 a la 10 (de un total de 10)
  • Debes estar registrado para responder a este debate.