Reglas de precios. (bug?)

Inicio Foros Foro principal Ayuda Reglas de precios. (bug?)

  • Este debate está vacío.
Viendo 6 entradas - de la 1 a la 6 (de un total de 6)
  • Autor
    Entradas
  • #31756

    HOla.

    Estoy creando reglas de precios, la creo con los siguientes parámetros:
    Companía: “nombre de la empresa”
    Regla de precios: Regla general
    Activo
    no check En cascada
    Tipo de divisa= Directa
    Entidad comercial = en blanco
    Subfamilia= Aceites
    Marca= cocinero

    Aquí el problema, cuando quiero aplicar esta regla a los aceites cocinero, no me discrimina por marca… impacta en todos los aceites sean de la marca que sean.

    Estoy errando en algún paso?

    Gracias.
    Saludos.

    #35651
    Dario Parente
    Miembro

    Estuve chequeando lo de las reglas de precios y si debe ser un bug ya que no trabaja como deberia la configuracion de regla de precios.
    He generado varias reglas de precios para tarifas de ventas de una misma empresa.
    Es decir por ejemplo.
    Para la empresa autonautica tengo una regla de precio autonautica.
    En reglas tengo varias creadas, pero no funcionan en dos casos.

    En una cree una regla (numero 1), que dice que a la EC autonautica subfamilia NADA, Tipo de ART. NADA, marca NADA me genere un precio de ventas que sera el precio de tarifa -20%.

    Bien esta regla lo que hace es que a todos los articulos de esta EC le aplique un descuento del 20% yme de el precio de ventas.
    Aplicandola funciona de 10.

    Bien luego creo otra regla (numero 5), que dice que a la EC Autonautica subfamilia amortiguadores, tipo suspension, marca NADA me genere el precio de tarifa -35%

    Al reaplicar todo para generar los precios me los genera perfectos, es decir primero genera la regla 1 que calcula para todos el descuento del 20% y luego aplica la regla 5 que solo me aplica en amortiguadores el descuento del 35%

    hasta aca creo estar en lo correcto y todo funciona bien.
    El problema viene de la siguiente manera.
    Yo al cargar las listas cargue articulos en distintas subfamilias, entonces tengo por ejemplo extremos marca thompson y marca mattioli, por lo que al ver los precios generados por mis reglas ambos tiene aplicados un descuento del 20%, perfecto.

    Ahora yo creo una nueva regla (numero 10)que me dice que a la EC autonautica, subfamilia extremos, tipo direccion, marca thompson me genere mi PV con un 25%.

    Al aplicar esto en tarifas para que me vuelva a generar los precios, veo que tengo la ultima regla bien aplicada para extremos thompson del 25%, pero al ver el preci de algun extremo mattioli tambien le aplico el descuento del 25% no respetando la regla que dice que solamente se aplique ese descuento a los extremos pero marca thompson.

    He probado creando en ves de la primer regla general una que me diga explicitamnete que a extremos mattioli le aplique otro descuento pero siempre me toma la ultima que esta guardada segun el numero de regla.
    Creo que es un bug como dice grauhaarig que le pasa con el aceite cocinero.
    El tema pasa porque las reglas validan subfamilia y no marca y deberian tambien validar marcas, porque sino se hace una ensalada a la hora de crear subfamilias.
    Se tendrian que crear subfamilias con marcas, es decir extremos thompson, extremo mattioli y asi para cada subfamilia que se tengan productos de distintas marcas.

    Me pueden confirmar si es asi, asi derivamos este tema a BUG.

    Gracias

    #35790

    dparente, es tal lo detallás! Lo he vuelto a probar y la generación de precios no tiene en cuenta la marca, aplica a todos los items de la subfamilia sea de la marca que sea… hoy con la inflación que hay, un día llega la factura de un proveedor con un incremento en tanto porciento y hay que indicar, dentro de la subfamilia, los productos de esa marca a mano.

    Otra sería poner la marca en la subfamilia tal como comentás.

    Gracias por probar la funcionalidad.

    Saludos.

    #35652
    Dario Parente
    Miembro

    Si de todos modos no seria lo mas factible crear subfamilias con marcas a la ves, en un rubro como por ejemplo ferreteria, repuestos automotor, supermercados,etc,etc, seria engorroso.
    Esperemos a ver que nos comenta algun moderador a ver si esta previsto para el nuevo release corregir esto y tendria que mover este asunto a desarrollo, porque no creo que este contemplado para que no valide marcas. Es un bug.

    Dario

    #35798
    Federico Cristina
    Superadministrador

    Darío,

    Como estás.
    Estuve revisando lo que indicás y efectivamente no se estaba filtrando por ciertos criterios, como por ejemplo las marcas.

    Hemos incorporado esta corrección en conjunto con una serie de ampliaciones en la generación de listas de precio, las cuales estarán incluidas en el nuevo release que está a punto de salir en estos días.

    Saludos,
    Federico

    #35653
    Dario Parente
    Miembro

    ok. gracias estaremos atentos a esos cambios para testearlos.

Viendo 6 entradas - de la 1 a la 6 (de un total de 6)
  • Debes estar registrado para responder a este debate.