psql:install.sql:55: ERROR: no existe el lenguaje

Inicio Foros Foro principal Instalación y Configuración psql:install.sql:55: ERROR: no existe el lenguaje

  • Este debate está vacío.
Viendo 4 entradas - de la 1 a la 4 (de un total de 4)
  • Autor
    Entradas
  • #31262

    Hola,
    estoy instalando la ultima version del servidor,
    sigo los pasos hasta psql -U postgres -f install.sql
    tira el siguiente error, en particular dice: psql:install.sql:55: ERROR: no existe el lenguaje «java»

    alguna idea?
    una diferencia que noté fue que la versior de JDK es 15 y no 16 como dice el instructivo de instalación

    Code:
    postgres@ubuntu-server:/home/pablo/pljava$ psql -U postgres -f install.sql
    psql:install.sql:1: ERROR: ya existe el esquema «sqlj»
    GRANT
    psql:install.sql:6: ERROR: no se pudo acceder al archivo «pljava»: No existe el fichero ó directorio
    psql:install.sql:8: ERROR: no existe la función sqlj.java_call_handler()
    psql:install.sql:12: ERROR: no se pudo acceder al archivo «pljava»: No existe el fichero ó directorio
    psql:install.sql:14: ERROR: no existe la función sqlj.javau_call_handler()
    psql:install.sql:23: NOTICE: CREATE TABLE creará una secuencia implícita «jar_repository_jarid_seq1» para la columna serial «jar_repository.jarid»
    psql:install.sql:23: ERROR: la relación «jar_repository» ya existe
    GRANT
    psql:install.sql:32: NOTICE: CREATE TABLE creará una secuencia implícita «jar_entry_entryid_seq1» para la columna serial «jar_entry.entryid»
    psql:install.sql:32: ERROR: la relación «jar_entry» ya existe
    GRANT
    ALTER TABLE
    psql:install.sql:43: ERROR: la relación «classpath_entry» ya existe
    GRANT
    psql:install.sql:50: NOTICE: CREATE TABLE creará una secuencia implícita «typemap_entry_mapid_seq1» para la columna serial «typemap_entry.mapid»
    psql:install.sql:50: ERROR: la relación «typemap_entry» ya existe
    GRANT
    psql:install.sql:55: ERROR: no existe el lenguaje «java»
    psql:install.sql:59: ERROR: no existe el lenguaje «java»
    psql:install.sql:63: ERROR: no existe el lenguaje «java»
    psql:install.sql:67: ERROR: no existe el lenguaje «java»
    psql:install.sql:71: ERROR: no existe el lenguaje «java»
    psql:install.sql:75: ERROR: no existe el lenguaje «java»
    psql:install.sql:79: ERROR: no existe el lenguaje «java»
    psql:install.sql:83: ERROR: no existe el lenguaje «java»
    psql:install.sql:87: ERROR: no existe el lenguaje «java»
    #34005

    Pablo,
    Primeramente, el java DEBE ser 1.6 y no 1.5. Sino no va a funcionar la aplicación.
    Luego de subsanado ese tema (que tal vez sea el origen del siguiente) tenes que seguir el instructivo de instalación en particular la parte de agregar el plJava que es lo que no está encontrando. Lo extraño es que si encuentra el esquema sqlj que se crea justamente cuando se instala el PLJava, por lo que me inclino por que el problema está en el java instalado en el equipo.
    Para evitar problemas, te conviene desinstalar cualquier otro java que no sea el java SUN 1.6 (ubuntu viene con gnujava además) y asegurarte que cuando ejecutas “java” sea la versión 1.6 (eso con java –version) y que el JAVA_HOME esté seteado contra la carpeta del java 1.6

    Saludos
    Antonio

    #34009

    Hola Antonio,
    Gracias por responder.

    Aclaración cuando dije:

    “una diferencia que noté fue que la versión de JDK es 15 y no 16 como dice el instructivo de instalación “

    quice decir:

    “una diferencia que noté fue que la versior de JDK es 1.6.0_15 y no 1.6.0_16 como dice el instructivo de instalación “

    por otro lado,
    java –version dice:

    Code:
    java version “1.6.0_15”
    Java(TM) SE Runtime Environment (build 1.6.0_15-b03)
    Java HotSpot(TM) Client VM (build 14.1-b02, mixed mode, sharing)

    lo extraño es que instalé un ubuntu server 9.10 x86 especialmente,
    siguiendo paso a paso exactamente como se dice acá: https://www.libertya.org/wiki/index.php/Guia_de_instalaci%C3%B3n_libertya_en_Linux_Ubuntu
    Quiero decir que el instructivo no dice nada en particular sobre la versión de sdk que viene ni nada al respecto…

    Otro error que olvide comentar, es que si trato de ejecutar
    psql -U postgres -f install.sql
    desde mi usuario dice:
    psql: FATAL: la autentificaci?n Ident fall? para el usuario <>

    lo Solucioné creando el usuario postgres y ejecutando desde ahí

    ¿ me estoy perdiendo algo ?

    Gracias nuevamente

    #34010

    Pablo,
    El usuario postgres debe estar creado antes de hacer todo eso.
    En los mensajes , lo primero es que no tenés permisos:
    psql:install.sql:6: ERROR: no se pudo acceder al archivo «pljava»: No existe el fichero ó directorio
    Te driría que re-verifiques todos los pasos del Wiki y ejecutes las cosas como root y no como “pablo” para evitar problemas de permisos (sudo su)

    Saludos
    Antonio

Viendo 4 entradas - de la 1 a la 4 (de un total de 4)
  • Debes estar registrado para responder a este debate.