Problema en migración de 14.02 a 15.03 SOLUCIONADO

Inicio Foros Foro principal Instalación y Configuración Problema en migración de 14.02 a 15.03 SOLUCIONADO

  • Este debate está vacío.
Viendo 1 entrada (de un total de 1)
  • Autor
    Entradas
  • #32987

    Buenas. Quería consultar sobre un inconveniente que se me está presentando al momento de correr el instalador de componentes para actualizar desde la versión 14.02 a la 15.03. Me encuentro trabajando en una máquina con Windows XP de 32 bits y el error que larga la ventana del programa es la siguiente (logueado con usuario System):

    “Error al realizar la post-instalación: Excepcion al ejecutar postInstall – Error starting Class org.openXpertya.process.release.PostInstallUpgradeFrom1402”.

    A su vez adjunto las últimas líneas que figuran en la consola (por la ejecución del libertya.bat):

    SQL: [7672]: INSERT INTO AD_Preference (AD_Client_ID,AD_ComponentObjectUID,AD_
    ComponentVersion_ID,AD_Org_ID,AD_Preference_ID,Attribute,Created,CreatedBy,IsAct
    ive,Updated,UpdatedBy,Value ) VALUES (0,’CORE-AD_Preference-1011194′,1010090,0,1
    011267,’LogTransactionEvents’,NOW(),0,’Y’,NOW(),0,’N’ );
    SQL: [7673]: INSERT INTO AD_Preference (AD_Client_ID,AD_ComponentObjectUID,AD_
    ComponentVersion_ID,AD_Org_ID,AD_Preference_ID,AD_User_ID,Attribute,Created,Crea
    tedBy,IsActive,Updated,UpdatedBy,Value ) VALUES (0,’CORE-AD_Preference-1011195′,
    1010090,0,1011268,101,’LogTransactionEvents’,NOW(),0,’Y’,NOW(),0,’X’ );
    SQL: [7674]: DELETE FROM AD_Preference WHERE AD_ComponentObjectUID = ‘CORE-AD
    _Preference-1011195′;
    === Comprobando secuencias de nuevos componentes – metadatos ===
    === Registrando informacion adicional del componente ===
    === Disparando proceso de postinstalaci├│n ===
    ===========> ProcessCtl.startProcess: org.openXpertya.process.release.PostInstal
    lUpgradeFrom1402 [66]
    java.lang.ClassNotFoundException: org.openXpertya.process.release.PostInstallUpg
    radeFrom1402
    at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:169)
    at org.openXpertya.apps.ProcessCtl.startProcess(ProcessCtl.java:596)
    at org.openXpertya.apps.ProcessCtl.run(ProcessCtl.java:293)

    Error al realizar la post-instalaci├│n: Excepcion al ejecutar postInstall – Err
    or starting Class org.openXpertya.process.release.PostInstallUpgradeFrom1402


    > Msg.getMsg: NOT found: Error al realizar la post-instalaci├│n: Exc
    epcion al ejecutar postInstall – Error starting Class org.openXpertya.process.re
    lease.PostInstallUpgradeFrom1402 [11]

    Agradecería cualquier tipo de ayuda para poder solucionar esto, ya que he intentando en diversas oportunidades realizar la instalación y no logro encontrar cual sea el problema.
    Saludos!



    Edito:

    Se me ocurrió volver a descargar los binarios y volver a pegarlos en la carpeta ServidorOXP y al correr la instalación, la misma se ejecutó sin problemas. Evidentemente el problema estaba en que algo se había descargado y/o descomprimido mal.
    Por suerte ya cuento con la nueva versión funcionando.

    Saludos

Viendo 1 entrada (de un total de 1)
  • Debes estar registrado para responder a este debate.