Problema al iniciar perfil de System Administrato

Inicio Foros Foro principal Instalación y Configuración Problema al iniciar perfil de System Administrato

Viendo 14 entradas - de la 1 a la 14 (de un total de 14)
  • Autor
    Entradas
  • #31705

    Hola, tengo un problema en una instalación reciente. Al tratar de
    acceder a la aplicación [img size=906]https://www.libertya.org/media/kunena/attachments/legacy/images/error1.JPG[/img] mediante el usuario System contraseña System, y seleccionar el perfil System Administrator, la aplicación simplemente no inicia. Se queda con el recuadro iniciando y de ahi no pasa.

    No tengo problema para acceder mediante el usuaro AdminLibertya la aplicaión carga perfectamente y me permite trabajar sin problemas…

    Alguien que me pueda apoyar con mi problema?, agradezco de antemano la atención.

    #35523
    Federico Cristina
    Superadministrador

    Buenas,

    Nunca había escuchado este problema. Se presenta algún error adicional en pantalla?

    Verificá si accediendo mediante usuario Supervisor (igual contraseña), y seleccionando el perfil System Administrator te ocurre el mismo problema.

    Saludos,
    Federico

    #35524

    Hola, gracias por tu pronta respuesta, probé con el usuario Supervisor y la misma contraseña, sigue con el mismo detalle, no muestra ningun error adicional en la pantalla. solo se queda intentando iniciar y de ahi no pasa….han pasado ya 10 mins y no arranca.

    Alguna idea?, o me recomiendas que vuelva a instalar el sistema..como te comentaba, es una instalación reciente asi que no tiene muchos datos cargados.

    #35525
    Dario Parente
    Miembro

    Hola.

    Que tipo de instalacion hiciste, es decir sistema operativo, versiones de mysql, java.
    Danos mas pistas.

    Trata de iniciar libertya a traves de una terminal para ver que tipo de error te esta dando.

    Dario

    #35526

    Hola, la instalación esta hecha en windows Xp, no tiene versiones de mysql, el pc solo tiene instalado libertya.
    El SO tiene todas su actualizaciones, el problema se dio despues de hacer una actualización de java, se instalaron un par de complementos en el explorador (Mozila) y al iniciar la aplicación se mostro un mensaje en pantalla el cual decía que dicho complemento tenía reporte de mal funcionamiento.

    Los complementos que se instalaron fueron:
    Java Quick Starter
    Java console 6.0.23
    Java Console 6.0.24

    #35527
    Dario Parente
    Miembro

    Tendrias que correr el cliente libertya desde consola de XP.
    Colocate en el directorio de libertya y ejecuta desde la consola el cliente.

    Es decir desde consola.
    C:/Directorio-Libertya/libertya.exe

    y fijate si te tira algun error y reportalo aqui.

    Dario

    #35528

    Hola, que tal. Corri el cliente como me lo indicaron, desde el directorio donde está instalado y tiene el mismo problema, con el usuario System, misma contraseña. La aplicación no inicia, con el usuario AdminLibertya misma contraseña, la aplicación inicia correctamente y permite agregar datos sin problema alguno.

    Debo comentar que esta instalado el plugin de talle y color, mismo que se instalo sin problemas. Despues de haber instalado el plugin y de haber hecho el SO una actualización de java, a partir de ese momento no pude entrar mas con el usuario System.

    #35537
    Federico Cristina
    Superadministrador

    Buenas,

    Hacé lo que sugiere dparente, salvo que deberías iniciar mediante:

    C:/Directorio-Libertya/utils/libertya.bat

    Si iniciás con libertya.exe, te devuelve el prompt y no muestra nada por la consola.

    Saludos,
    Federico

    #35571
    Gustavo Borchez
    Participante

    Gente ¿solucionaron? Acabo de notar que tengo una instalación que no me permite ingresar como System. Iniciando desde cmd como indica Federico tira lo siguiente:

    Microsoft Windows XP [Versión 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:>C:ServidorOXPutilslibertya.bat
    *** 2011-11-03 19:58:24.312 OpenXpertya Log (CLogConsole) ***
    19:58:23.718 OpenXpertya.startup: Libertya (r) Versi├│n 11.05_31-05-2011 – Softw
    are Libre de Gesti├│n- (c) 2011 DISYTEL; Implementaci├│n: Versi├│n 11.05 2011071
    7-1558 – ${env.CONSULTORA_OXP}
    19:58:23.718 OpenXpertya.startup: C:ServidorOXP – Java HotSpot(TM) Client VM 14
    .0-b16 – Windows XP 5.1 Service Pack 3


    > CConnection.setAppsServerInfo: jnp://localhost:1099
    – javax.naming.CommunicationException: Receive timed out [Root exception is jav
    a.net.SocketTimeoutException: Receive timed out]
    – {java.naming.provider.url=jnp://localhost:1099, java.naming.factory.initial=o
    rg.jnp.interfaces.NamingContextFactory, jnp.discoveryTimeout=5000, jnp.timeout=5
    000, java.naming.factory.url.pkgs=org.jboss.naming:org.jnp.interfaces, jnp.sotim
    eout=5000}
    Exception occurred during event dispatching:
    java.lang.NullPointerException
    at org.openXpertya.util.Login.loadPreferences(Login.java:993)
    at org.openXpertya.apps.ALogin.defaultsOK(ALogin.java:788)
    at org.openXpertya.apps.ALogin.actionPerformed(ALogin.java:651)
    at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:19
    95)
    at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.jav
    a:2318)
    at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel
    .java:387)
    at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242
    )
    at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonL
    istener.java:236)
    at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:2
    72)
    at java.awt.Component.processMouseEvent(Component.java:6263)
    at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
    at java.awt.Component.processEvent(Component.java:6028)
    at java.awt.Container.processEvent(Container.java:2041)
    at java.awt.Component.dispatchEventImpl(Component.java:4630)
    at java.awt.Container.dispatchEventImpl(Container.java:2099)
    at java.awt.Component.dispatchEvent(Component.java:4460)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574
    )
    at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)

    at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
    at java.awt.Container.dispatchEventImpl(Container.java:2085)
    at java.awt.Window.dispatchEventImpl(Window.java:2475)
    at java.awt.Component.dispatchEvent(Component.java:4460)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThre
    ad.java:269)
    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.
    java:184)
    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.
    java:178)
    at java.awt.Dialog$1.run(Dialog.java:1045)
    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThre
    ad.java:269)
    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.
    java:184)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThre
    ad.java:174)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)

    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)

    at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

    //Hasta acá queda colgado en la pantalla de ingreso, loading preferences. Si se cierra pulsando la “X” salta a las línes siguientes y devuelve el prompt

    *** 2011-11-03 20:05:55.75 OpenXpertya Log (CLogConsole) ***
    “sleep” no se reconoce como un comando interno o externo,
    programa o archivo por lotes ejecutable.

    C:>C:ServidorOXPutilslibertya.bat

    ¿Alguien que sepa de qué estamos hablando???

    #36168

    En mi caso, el problema se dio despues de modificar los datos generales de la empresa en el perfil de administrador. Por error o ignorancia. Nunca lo pude solucionar y tuve que instalar de nuevo Libertya…espero que no sea tu caso…saludos

    #36169
    Gustavo Borchez
    Participante

    Concluyo que hay algo roto en la DB, porque arrancando la misma instalación con otra DB entra perfecto. Sigo investigando…

    #36170
    Gustavo Borchez
    Participante

    Lo que está roto es lo concerniente al perfil y no al usuario… Le di permiso a AdmiLibertya y se me traba cuando inicio como System Administrator (con todos los otros pefiles entra sin problema). ¿Que tabla guarda esos datos? (Me recorrí las 648 tablas y no encontré cuál asigna los permisos para seguir rastreando)….

    #36171

    Hola, si no mal recuerdo. Yo quite la tilde a las opciones de los paises….quería que solo tuviera activo el de México, y quite todos…entre ellos Argentina. Además, también cambie la información que tiene por default la empresa (Dirección datos generales, etc.). Posteriormente ya no pude tener acceso al perfil de administrador. A los perfiles de usuario si podia accesar sin mayor problema.

    Como te comento nunca hubo alguien que me pudiera auxiliar con el problema y tuve que hacer una instalacion nueva.

    Saludos……

    #36172
    Gustavo Borchez
    Participante

    … Bien…

    Chusmeando en las bases de datos encontré que la compañía System tenía configurado el idioma Español España en vez de Español Argentina (en ad_languaje.ad_client) Lo cambié para es_AR y logré entrar a System sin problemas.

    Evidentemente toqueteando deshabilité o cambié algo en idiomas o paises… Para probar partí de la experiencia de liquiddigital que había deshabilitado todo menos Méjico…

    Sigo sosteniendo que el empirismo es la corriente que más vidas salvó a lo largo de la historia!!!

Viendo 14 entradas - de la 1 a la 14 (de un total de 14)
  • Debes estar registrado para responder a este debate.