Problema al agregar Entidad Comercial

Inicio Foros Foro principal Ayuda Problema al agregar Entidad Comercial

Viendo 15 entradas - de la 1 a la 15 (de un total de 18)
  • Autor
    Entradas
  • #48816
    Diego Rucci
    Participante

    Recientemente hice la actualización a Libertya 19.07.
    Hoy quise dar de alta un cliente, asi que fui a Entidades Comerciales, completé los datos y al pulsar Guardar veo una ventana de error con esta información:

    No se pudieron guardar los cambios:
    La configuración de lote de pagos debe estar completa.
    Se deben completar todos los campos correctamente para que el proceso tome la entidad comercial en el proceso descrito.

    No supe encontrar donde y cómo configurar lote de pagos.

    Finalmente lo pude resolver copiando de otra EC y editando.

    ¿Alguna sugerencia o documentación que pueda leer?
    Muchas gracias

    #48825
    Horacio Alvarez
    Participante

    Buen Dia Diego,
    no debería pedirte los datos de un lote de pagos para cargar un cliente. Cuando guardaste la EC, la guardaste como Cliente o como Proveedor ?

    Otra consulta, ya habías estado trabajando con Lotes de Pagos ?

    Saludos!

    #48828
    Diego Rucci
    Participante

    Hola Horacio. Gracias.

    Directamente no me deja guardar la EC (desde el perfil de administración, no he probado desde ventas). Da el error expuesto.

    Nunca trabajé con lotes de pagos. Mi configuración es muy simple.

    Soy monotributista que brinda servicios.

    Y mi cartera de clientes no tiene grandes cambios, por eso no me di cuenta hasta este mes que quise agregar un nuevo cliente.

    No tengo artículos ni manejo stock.

    Tenes alguna documentación que indicarme para leer?
    Mucha gracias.

    #48831
    Jorge Matulich
    Participante

    Buen día Diego

    Nos sería de utilidad que puedas reproducir el problema y enviarnos una captura de la pantalla, la entidad comercial no debería tener algún tipo de validación con los lotes de pago. Inclusive esa validación podría estar activandose por alguna configuración de valor preferido que exista en la ventana de Entidades Comerciales.

    Si querés profundizar sobre cualquiera de estos temas, te invitamos a las sesiones semanales gratuitas de Consultoría On Line. Más información en https://www.libertya.org/forums/topic/documentacion-completa-y-soporte-libre-para-libertya-pyme-3/

    #48836
    Diego Rucci
    Participante

    Hola, el error aparece tanto en perfil de administración como de ventas.

    Para asegurarme también utilicé el usuario AdminLibertya.

    Estoy utilizando el cliente pesado (y además hice la prueba desde el cliente webui)

    Al cargar una nueva EC, cargo el formulario principal y al pulsar el botón guardar aparece el error.

    cliente webui

    cliente pesado

    • Esta respuesta fue modificada hace 1 año, 12 meses por Diego Rucci.
    #48838
    Diego Rucci
    Participante

    Agrego.
    Si selecciono alguna opción de IIBB (por ejemplo convenio multilateral o regimen simplificado),
    no aparece el campo para ingresar el nro de IIBB, debo cambiar a vista de rejilla para cargarlo.

    ¿Debería re-generar el servidor ejecutando Configurar.sh (estoy bajo linux)?

    #48844
    Horacio Alvarez
    Participante

    Buenas Tardes Diego,
    podrías verificar si en la ventana de Entidades Comerciales, pestaña Proveedor tenés algo seteado por defecto en el grupo de campos “Configuración de Lotes de Pagos” ?. En tal caso fijate que las cuentas bancarias no tengan la tilde “Cuenta de Pagos Electrónicos”

    Y verifica también la ventana Lotes de Pagos, si tenés algo cargado ahí, borralo, elimina el registro.

    Saludos!

    Si querés profundizar sobre cualquiera de estos temas, te invitamos a las sesiones semanales gratuitas de Consultoría On Line. Más información en https://www.libertya.org/forums/topic/documentacion-completa-y-soporte-libre-para-libertya-pyme-3/

    #48848
    Diego Rucci
    Participante

    Hola, tal como indiqué, no puedo ver qué hay en otras pestañas de la ventana de EC
    porque no me deja guardar siquiera el nombre de la EC sin que aparezca el error (ergo no puedo cambiar de pestaña).
    Ninguna cuenta bancaria tiene tilde de pagos electrónicos.
    En Configuración de Lotes de Pago tampoco tengo nada cargado.

    Traté de explorar con el usuario System en la ventana de Bussiness Partner, pero tampoco estoy muy seguro de qué buscar.

    #48872
    Jorge Matulich
    Participante

    Buen día Diego

    Deberías fijarte en alguna EC existente sobre la pestaña Proveedor tenes algún dato que tenga relación con la configuración de lote de pagos que posiblemnte tenga algún valor predeterminado y por ese motivo te este generando el problema, o en su defecto aunque menos probable que en metadatos tenga un valor por defecto.
    En la ventana Valores Predeterminados con el perfil Configuración de la compañia tenes la ventana Valores predeterminados, tenes que identificar previamente el nombre de la columna como atributo.

    Saludos

    Si querés profundizar sobre cualquiera de estos temas, te invitamos a las sesiones semanales gratuitas de Consultoría On Line. Más información en https://www.libertya.org/forums/topic/documentacion-completa-y-soporte-libre-para-libertya-pyme-3/

    #48924
    Escanort
    Participante

    Buenas tardes,

    Lo solucione como indicó Jorge:
    En la ventana Valores Predeterminados con el perfil Configuración de la compañia tenes la ventana Valores predeterminados, tenes que identificar previamente el nombre de la columna como atributo.
    Atributo: Batch_Payment_rule
    Clave de búsqueda: -1, la cambie por 0 y funcionó.

    Saludos

    #48982
    Pablo Corace
    Participante

    Tengo el mismo problema con un cliente que actualizó a la versión 19.07. No tiene configurada ninguna preference referida a lote de pagos (ni forma de pago, ni cuenta bancaria) sin embargo, debugueando un poco, vi que invariablemente pasaba por la validación:
    // La configuración de lote de pagos debe estar completa
    if ((!Util.isEmpty(getBatch_Payment_Rule(), true) && Util.isEmpty(getC_BankAccount_ID(), true))
    || (Util.isEmpty(getBatch_Payment_Rule(), true) && !Util.isEmpty(getC_BankAccount_ID(), true))) {
    log.saveError(“SaveError”, Msg.getMsg(getCtx(), “NotValidBatchPaymentVendorConfiguration”));
    return false;
    }
    en el beforesave de MBPartner. Comentando esa validación pude salvar los cambios.
    El tema es que, una vez salvada la entidad comercial con la validación comentada, si voy a la pestaña proveedor y tildo proveedor para que habilite los campos, en cuenta corriente de lote de pagos aparece por defecto la cuenta del único banco que está configurado. Creo que habría que modificar esa validación para que sólo actúe cuando IsVendor=’Y’ y ver por qué ese campo toma ese valor por defecto ya que no veo nada en preference ni en metadatos que provoque este comportamiento.
    Saludos

    • Esta respuesta fue modificada hace 1 año, 9 meses por Pablo Corace.
    #48985
    Matías Nerón Cap
    Superadministrador

    Buenas,

    Al parecer es un error de la versión, se da porque a las columnas que poseen idéntico nombre a algún dato global del contexto (las variables que comienza con #), el sistema le setea un valor por defecto que es el correspondiente a la variable del contexto. Luego, al pasar por la validación no deja continuar con la operación.

    La solución adaptada fue agregarle el valor “null” como Lógica Predeterminada de la columna C_BankAccount_ID de la tabla C_BPartner. Incluso con los valores 0 y -1 daba el mismo error.

    Saludos!

    #48986
    Pablo Corace
    Participante

    Gracias Matías!

    #49009
    dbravo
    Participante

    Hola Matías, estoy teniendo el mismo problema. Podrías indicarme con un poco más de detalle dónde y cómo hay que hacer los cambios que mencionás?.
    Mil gracias!
    Daniel

    • Esta respuesta fue modificada hace 1 año, 8 meses por dbravo.
    • Esta respuesta fue modificada hace 1 año, 8 meses por dbravo.
    #49012
    Federico Cristina
    Superadministrador

    Daniel,

    Cómo estás?

    Para realizar modificaciones como la que indica Matías, se requiere ciertos conocimientos de parametrización de Libertya. Deberás modificar los metadatos de la aplicación, accediendo al sistema bajo el perfil System Administrator.

    Una vez en dicho perfil, ir a la ventana Tabla y Columna, buscar la tabla C_BPartner y posteriormente ir a la entrada C_BankAccount_ID en la subpestaña de columnas, en donde podrás modificar la lógica predeterminada de dicha columna.

    De más está decir que hay que proceder con cuidado cuando se realizan modificaciones sobre los metadatos de la aplicación.

    Saludos!

Viendo 15 entradas - de la 1 a la 15 (de un total de 18)
  • Debes estar registrado para responder a este debate.