No me quiere iniciar libertya en Ubuntu ./Libertya

Inicio Foros Foro principal Instalación y Configuración No me quiere iniciar libertya en Ubuntu ./Libertya

  • Este debate está vacío.
Viendo 3 entradas - de la 1 a la 3 (de un total de 3)
  • Autor
    Entradas
  • #31250
    Yanina Aular
    Miembro

    Hola, como estan?, tengo un problema, quiero iniciar Libertya desde mi servidor en el cual tengo instalado Ubuntu, tengo mi JAVA_HOME Y OXP_HOME configurado de la siguiente manera:

    export JAVA_HOME=/usr/java/jdk1.5.0_19
    export OXP_HOME=/ServidorOXP

    pero entonces cuando inicio el ./Libertya.sh no me funciona y me lanza el siguiente error

    synergix@sistemas3:/opt/ServidorOXP/utils$ ./Libertya.sh
    Cliente Libertya v9.07 /opt/ServidorOXP
    Exception in thread “main” java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)

    #33964
    Yanina Aular
    Miembro

    YA lo resolvi jejej tenia que configurar mi JAVA_HOME con otro enlace

    export JAVA_HOME=/usr/lib/jvm/java-6-sun

    #33965

    Correcto. necesitas Java 6 para ejecutar las versiones 9.07 y 9.10 de Libertya. Si tenés ambas versiones de Java , es posible que tengas problemas con la versión que toma la base de datos. verifica si el SQLJ está funcionando. Si ingresas a la ventana de consulta de artículos (CTRL+I) y te muestra los que hayas dado de alta, es que está funcionando. Si no muestra nada, es por eso.

    Saludos
    Antonio

Viendo 3 entradas - de la 1 a la 3 (de un total de 3)
  • Debes estar registrado para responder a este debate.