No me aparece para instalar el PL/JAVA

Inicio Foros Foro principal Instalación y Configuración No me aparece para instalar el PL/JAVA

  • Este debate está vacío.
Viendo 6 entradas - de la 1 a la 6 (de un total de 6)
  • Autor
    Entradas
  • #31485

    buenas, estoy intentando instalar el sistema siguiendo las indicaciones en la wiki pero a la hora de instalar el Postgres, no me aparece el pl/java para instalar, no me aparece nada de las cosas que dicen en la wiki, solo el directorio donde voy a instalar el postgres y ya, despues empieza a instalarlo.
    lei que quizas podia influir las variables de entorno como estuviesen configuradas, tengo instalada la JDK y el JRE, transcribo como tengo las variables de entorno a ver si algo esta mal con eso o no se la verdad.

    CLASSPATH: C:Javajdk1.6.0_21
    JAVA_HOME: C:Javajdk1.6.0_21
    OXP_HOME: C:ServidorOXP
    Path: %JAVA_HOME%;%SystemRoot%system32;%SystemRoot%;%SystemRoot%System32Wbem;%SYSTEMROOT%System32WindowsPowerShellv1.0;C:Program FilesWIDCOMMBluetooth Software;C:Program FilesWIDCOMMBluetooth Softwaresyswow64;%JAVA_HOME%bin;C:Javajdk1.6.0_21jrebinclient;C:PostgreSQL8.3bin

    no se si me falta alguna variable mas, entiendo que no
    se puede instalar el pl/java despues de instalar el postgresql? porque si no me aparece al principio quizas lo pueda instalar luego
    desde ya, muchas gracias

    Nicolas

    #34840

    Seguramente estan mal seteadas las variables de entorno. En la documentación oficial de Postgres para cada versión te indica los valores que tenes que tener seteados para que se active la casilla de pl/java en la instalación.

    #34846

    Hola, supuse que eran las variables de entorno, por eso ahi copie las que tenia seteadas para, si alguien las sabia, me las corrigiera de favor.
    Ya que estuve buscando una documentacion sobre pljava en Postgresql y encontre unas cositas pero en ninguna habla de como deben esta seteadas las variables de entorno para que aparezca la opcion de instalar el pljava durante la instalacion del postgresql.
    encontre esta

    http://pljava.projects.postgresql.org/

    y no dice nada, solo da links pero q tampoco llevan a ninguna documentacion, tambien esta pero nada…

    http://pgfoundry.org/projects/pljava/?readme

    por favor, si alguien me puede dar una mano con esto se los agradeceria muchisimo.
    mientras sigo investigando
    gracias

    Nicolas

    #34841
    Javier Ader
    Participante

    Yo te diría que no intentes instalar pl/java por separado y por ej uses el instalador automático el cual te instala Postgres y PL/Java sin problemas (el instalador automático no te muestra el dialogo para seleccionar pl/java porque esta configurado para hacerlo automáticamente).
    Como lo hace, exactamete no lo se, pero podes descomprimir el .exe del instalador (lo abris como si fuera un archivo .zip, por ej, como 7zip) y vas a ver que contiene en por un lado el instalador de Postgres y otro “subinstaldor” (es otro exe, que no recuerdo el nombre, te vas a dar cuenta), para instalar pl/java (creo que ademas instala otras extensiones de postgress).
    Si queres usar ese instalador el modo de hacerlo es poner en un directorio el instalador base de postgress y el “subinstalador” dentro del mismo directorio y despues ejecutas el instalador base (este instalador “mira” si en el mismo directorio aparece un instalador de extensiones y lo invoca). Ahi creo que te va a aparecer el dialogo para seleccionar pl/java tal como lo muestra la wiki (el tema es que la wiki esta medio desactualizada…).
    Igual, no te compliques y usalo de manera directa (e.d sin descomprimir el instalador) que es mas simple. El unico problema que podes llegar a tener es que tengas que desinstalar previamente el postgres (el instalador automatico detecta si hay una versión ya instalada, y si la hay saltea la instalación de postgres) ya instalado y eliminar el usuario postgres (busca en el foro que esta como hacerlo).

    #34849

    hola, al fin logre hacer que funcione el pljava
    tal como me respondio javAd tuve que usar el instalador de PostgreSQL que viene dentro del instalador de Libertya.
    Independientemente de como esten seteadas las variables de entorno (no influye para nada), para poder instalar el pljava hay que usar el instalador que viene dentro del .exe de Libertya y no hay otra. No funciona con ningun otro instalador de PostgreSQL, ya lo intente con las ultimas 3 versiones.
    gracias por las contestaciones
    saludos

    Nicolas

    #34856

    Me alegro que hayas solucionado el problema. Sin embargo, que uno de los factores para la correcta configuración del pl/java depende de las variables de entorno, no es una afirmación de mi autoría sino de PostgreSQL.

    Aunque muchas personas hemos instalado el pl/java en Postgres 8.3 sin necesidad del instalador de LY (de hecho el instalador no existía en la 1era versión), obviamente dicha opción es mucho mas simple.

Viendo 6 entradas - de la 1 a la 6 (de un total de 6)
  • Debes estar registrado para responder a este debate.