Migracion de 10.03 a 10.09 – problemas

Inicio Foros Foro principal Ayuda Migracion de 10.03 a 10.09 – problemas

  • Este debate está vacío.
Viendo 6 entradas - de la 16 a la 21 (de un total de 21)
  • Autor
    Entradas
  • #35320
    Federico Cristina
    Superadministrador

    Buenas,

    Me tomé el trabajo de verificar la actualización de LY10.03 a LY10.09 bajo PostgreSQL 8.3 (ya que todos los tests fueron realizados en 8.2) en Ubuntu. Seguí el instructivo paso por paso y no tuve problema alguno.

    Estoy al tanto que la actualización funciona correctamente, como por ejemplo se comenta en este thread, y también en este otro.

    Creo que luego de haber realizado tantas pruebas, lo más sencillo es que pruebes primeramente “desde 0” en una instancia limpia, y a partir de ahí sacar las conclusiones de por qué estás teniendo inconvenientes en tu instancia.

    Te adjunto la bitácora de actualización, en caso de que te sea de utilidad.

    Saludos,
    Federico [file name=Component_install_20101128_124321.zip size=135501]https://www.libertya.org/media/kunena/attachments/legacy/files/Component_install_20101128_124321.zip[/file]

    #35144
    Carranza Carlos
    Participante

    Qué versión de Ubuntu utilizaste para instalar postgresql8.3?
    Te pregunto porque con 10.04 hay que hacer algunpos malavarismos (tuve que instalar paquetes de Debian para hacerlo y bloquear 8.4).
    De todas maneras me puse a probar con Windows.
    Tenía una instalación con libertya 10.03 de hace un tiempo y traté de migrarla.
    Llegué hasta más adelante en la migración, pero vuelta a clavarse, y sin generar log (parece que los log tienen un problema de gps, porque no se generan en mi domicilio).
    ==Instalando Componente y Version. Registrando plugin==
    ==Ejecutando sentencias de preinstalacion==
    ==Comprobando secuencias de nuevos componentes-preinstalacion==
    ==Insertando metadatos de instalacion==
    Y ahí quedó.

    Por último tomé una máquina virtual de windows sin ningún tipo de instalación, le instalé libertya10.03, configuré, etc.
    Después comencé la migración y nuevamente problemas (por supuesto sin log)
    === Instalando Componente y Version. Registrando Plugin ===
    === Ejecutando sentencias de preinstalacion ===
    Error al realizar la instalación: ERROR: there is no unique constraint matching given keys for referenced table “ad_electronicinvoiceformat”
    Digamos que la tabla no tiene índice único por lo tanto no puede generar una relación sobre la misma.

    Cómo hiciste para que te funcionara? Versión de Ubuntu, versión de postgresql, pasos de instalación, etc…

    #35145
    Carranza Carlos
    Participante

    Creo que le encontré la punta al ovillo.
    Con la misma máquina virtual – Ubuntu 10.04, Postgresql8.3.
    Con la misma base de datos que no migraba.
    Cantidad de memoria asignada a la máquina virtual 384 Mb
    Subí cantidad de memoria a 768 Mb y regeneré desde el backup la base de datos (ya había hecho la actualización de los binarios).
    Lancé la migración y comenzó a funcionar :
    – generó el log
    – llenó la consola de migración y el log con los mensajes (el log los mensaje más largos, con más detalle).
    – No terminó, se plantó en la postinstalación, pero los mensajes en el log no son lo suficientemente explicativos. Copio las 3 últimas líneas :

    === Comprobando secuencias de nuevos componentes – metadatos ===
    === Disparando proceso de postinstalación ===
    Error al realizar la instalación: Instalacion cancelada en post configuracion!

    Revisando el log he visto algunos errores como de borrado de registros, en vez de desactivado. Será esto lo que produce el error?
    Alguna sugerencia?
    Cómo hago para adjuntar el archivo de log?

    #35335
    Federico Cristina
    Superadministrador
    Quote:
    Error al realizar la instalación: Instalacion cancelada en post configuracion!

    Esto me da la pauta de que algo muy raro esta ocurriendo, dado que para la actualización de LY 10.03 a la 10.09 NO hay definido un proceso de post-instalación.

    Estás utilizando la máquina virtual correcta? Deberías utilizar la JDK 6 de Oracle (anteriormente de Sun), y no OpenJDK.

    Estás descargando el archivo correcto, sin haber realizado modificaciones al manifest.properties?

    Saludos,
    Federico

    #35146
    Carranza Carlos
    Participante

    Por fin lo pude solucionar, y gracias a las ayudas del foro y en especial a Federico.
    El problema era el Java, estaba usando OpenJDK y no el JDK de sun.
    Hay que usar JDK 6 de sun.
    Después de desinstalar OpenJDK, instalar JDK de sun (habilitar los repositorios e instalar), revisar los archivos de environment, configuración de postgreSQL y PlJava (reiniciando postgreSQL) e instalé los componentes bajando la memoria de la máquina virtual hasta donde estaba originalmente y funcionó en todos los casos.

    #35349
    Federico Cristina
    Superadministrador

    Me alegra que hayas podido realizar la actualización!

    Gracias por compartir la solución al problema, seguramente le será de utilidad a otros usuarios.

    Saludos,
    Federico

Viendo 6 entradas - de la 16 a la 21 (de un total de 21)
  • Debes estar registrado para responder a este debate.