Libertya 10.09, Ubuntu 10.10, PostgreSQL 8.4

Inicio Foros Foro principal Instalación y Configuración Libertya 10.09, Ubuntu 10.10, PostgreSQL 8.4

  • Este debate está vacío.
Viendo 6 entradas - de la 1 a la 6 (de un total de 6)
  • Autor
    Entradas
  • #31729
    Diego Rucci
    Participante

    Sólo quería comentarles que pude realizar la instalación sin ningún tipo de problemas utilizando íntegramente los paquetes que proporciona Canonical en sus repositorios.

    Varias veces traté de seguir las guías existentes (las de ubuntu ya están algo desactualizadas) y probé con CentOS, y la verdad por momentos se me complicaba y llegaba a puntos sin retorno.
    Por ejemplo, la versión 8.3.7 de postgresql no existe para descargar desde ninguna parte, ni siquiera desde la página oficial.

    Así que por probar, quise ver si con los paquetes propios de ubuntu funcionaba y he aquí el resultado.

    Me queda comprobar que no existan errores y que sea completamente operativo.

    El esquema de instalación fue el siguiente:
    [ul][li]Ubuntu 10.10 (instalación estándar y actualización al 06/04/2011)[/li]
    [li]PostgreSQL 8.4[/li]
    [li]openjdk-6-jdk (java libre del proyecto IcedTea)[/li][/ul]

    desde línea de comandos:

    Code:
    $ sudo apt-get install pgadmin3 postgresql-8.4 default-jdk openjdk-6-jdk

    Una vez instalado los paquetes, seguí las instrucciones de configuración de acuerdo a la wiki.

    Instalé pljava 1.4.2 (ya que es el correspondiente a la versión 8.4 de postgresql) sin errores e inicié el servidor OpenXPertya sin problemas.

    Me pude conectar desde otro equipo y lancé la aplicación web sin inconvenientes.

    Reitero, me queda investigar a fondo y verificar que no haya problemas.
    ¿Alguien ha probado ya?

    Lo que voy a tratar de hacer es replicar los pasos de instalación para poder brindar alguna página en la wiki.

    Saludos

    #35578

    Muy bueno! Verificaste esto?

    #35579
    Diego Rucci
    Participante

    A ver… primera vez que incursiono en un ERP, asi que estoy verde, verde.

    Cuando entro a “Estado de Cuenta EC” me pide Entidad Comercial, rango de dias y tipo de cuenta.

    En Entidad comercial solo veo AFIP y CF, y al seleccionar uno y definir tipo de cuenta, efectivamente me aparece:

    ** Estado De Cuenta de EC
    ** ERROR: no existe la relación Position: 3237

    Detengo el servidor, detengo postgresql y ejecuto ambos comando citados en el link que pasaste.

    Reinicio postgresql y el servidor de libertya y vuelvo a probar pero sigue apareciendo lo mismo.

    Se debe a pl/Java ?? no dió ningún tipo de error al instalarlo.

    #35583

    hola buenas! mira a mi me salia ese error y se debe a que esa relaicon “rv_payment” es una vista que tiene que estar creada en la base de datos.En total tendrias que tener como minimo 126 vistas, una de estas es “rv_payment”.Deberias revisar que todo este bien en la base de datos…una solucion que te propongo es tomar una backup de una BD que tenga todas las vistas y tablas, y restaurar tu base con ese backup

    #35602
    Diego Rucci
    Participante

    Gracias phantom, el problema es que es una instalación nueva, de cero… no hay BD previa, ni backup.
    Seguí la guía de instalación y levanté el dump de libertya 10.09, nada mas.

    #35606

    mira lo que podes hacer que me funciono, es usar el instalador automatizado de windows(en una maquina con windows) y una vez que termine de instalar todo le haces un backup a esa base limpia y con ese backup levantar la base tuya.No deberias tener ningun problema…de esa manera vas a tener todas la vistas que el sistema necesita…Por otro lado te diria que verifiques minuciosamente la instalacion del pl/java y la compatibilidad de todos los paquetes…
    Saludos!

Viendo 6 entradas - de la 1 a la 6 (de un total de 6)
  • Debes estar registrado para responder a este debate.