Instalación en Linux Debian 7

Inicio Foros Foro principal Instalación y Configuración Instalación en Linux Debian 7

  • Este debate está vacío.
Viendo 6 entradas - de la 1 a la 6 (de un total de 6)
  • Autor
    Entradas
  • #32658

    Buenos días. Estoy intentando seguir la guía de instalación para Ubuntu y Debian.
    La versión de postgres que me ofrece mi sistema (por medio de synaptic) es postgres9.1
    Cuando intento instalar java6, me ofrece java7.
    Ya he intento realizarlo en un maquina virtual y no logre hacerlo funcionar.
    Me gustaría saber si existe alguna actualización del tutorial o alguna forma de instalar las versiones necesarias para libertya (sin generar un problema de dependencias).
    Desde ya, muchas gracias, que tengan un excelente día.

    #38267
    Luis Alberto Toba
    Participante

    Estimado, como bien estas intentando Libertya requiere de Oracle Java 6 y PostgreSQL 8.4, por no ser estas las ultimas versiones de los mismos no vea a poder instalarlos mediante los repositorios de debian. Para instalar Java6, busca por google y vas a encontrar el archivo .deb de java6 correspondiente a tu arquitectura. Por otro lado para instalar postgresql si ingresas a la pagina vas a encontrar todas la versiones, la ultima que funciona correctamente con Libertya v8.4.20

    Saludos

    #38268
    María Castro
    Participante

    Hola no se si ya has podido solucionar el problema, pero te pongo una guía que me sirvió a mi para instalar postgreSQL. La saqué de otra página que ahora no recuerdo ya que lo copié a un txt.



    A continuación vamos a explicar como seria el proceso de instalación de PostgreSQL con este instalador. Independientemente del sistema operativo usado, debería de funcionar de la misma manera.

    Lo primero que tenemos que hacer es descargar la versión del programa de instalación que corresponda con nuestro sistema. En nuestro caso nos descargamos desde http://www.enterprisedb.com/products/pgdownload.do la versión libre para la comunidad la ‘9.3.4’ para Linux x86-32 y 64 bits o la versión que uds. eligan.

    Una vez descargado lo descomprimimos en alguna carpeta.
    Para instalarlo lo tendremos que ejecutar como administrador en nuestro sistema. Conviene abrir la terminal y arrancar dolphin o nautilus como root. En mi caso como tengo Kubuntu usé:

    sudo dolphin

    Antes de instalar

    1° Debes hacer Click derecho sobre el archivo postgresql-9.3.4.3-linux-x64.run (el nombre del archivo puede variar dependiendo de la versión que descarguen) y en la solapa Permiso seleccionar “Permitir ejecutar el archivo como un programa” o “es ejecutable”. Luego cerrar.

    2° Luego Click dos veces sobre el archivo postgresql-9.3.4.3-linux-x64.run y seguir los pasos de la instalación.

    En un momento pide el codigo de caracteres o algo similar, yo elegí es_AR_utf8 y antes de finalizar destildar en la última pantalla la única opción que te da, donde dice si se quiere lanzar Stack Builder.

    Espero que te sirva, ya que he visto en estos foros que siempre mandan al manual de instalación pero está muy desactualizado.
    Yo aún no he podido instalar el programa debido a errores al querer realizar los pasos de instalación.. veré como lo soluciono..

    Saludos
    María.

    #38269
    Juan Manuel Martínez
    Participante

    Hola,

    No te recomiendo instalar versiones de la rama 9 de PostgreSQL. Encontré una incompatibilidad en una función almacenada que impide sacar algunos reportes del sistema. Muy probablemente haya otras.
    Por lo tanto te recomiendo instalar la versión 8.4 que está probada y funciona bien. En el sitio de PostreSQL encontrarás las instrucciones para agregar los repositorios con la versión 8.4 para Wheezy.

    Con respecto a Java, debés buscar en el sitio de Oracle el paquete tar.gz que contiene la versión 6 de java e instalarla manualmente (es decir, no pasa por APT). Te recomiendo bajar la versión 1.6.0_22 y ubicarla en el directorio /opt. Luego, en la instalación de Libertya, indicar la ruta /opt/jdk1.6.0_22 como base de Java. Esto te permite instalar otras versiones de Java para otras aplicaciones (por ejemplo, para utilizar el plugin de los navegadores).

    Saludos,
    Juan Manuel.

    #38270

    Hola a todos. Aunque todavía no sé si funcionó o no, me sirvió mucho esta guia para instalar java 6 en Debian 7. Lo que no aclara es que los paquetes descargados hay que guardarlos en la carpeta “sun-java6” y si no lo hacen, aparecerá un error al ejecutar “dpkg-buildpackage -uc -us”

    #38271

    Para instalar el paquete postgresql-8.3 en Debian Wheezy GNU/Linux hice lo siguiente:

    = Install package postgresql-8.3 on Debian Wheezy GNU/Linux =
    echo "deb http://apt.postgresql.org/pub/repos/apt/ wheezy-pgdg main" > /etc/apt/sources.list.d/postgresql.list2
    wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | apt-key add -
    apt-get update && apt-get dist-upgrade && apt-get install postgresql-8.3

Viendo 6 entradas - de la 1 a la 6 (de un total de 6)
  • Debes estar registrado para responder a este debate.