Error starting Class org.openXpertya.JasperReport.ReportStarter

Inicio Foros Foro principal Ayuda Error starting Class org.openXpertya.JasperReport.ReportStarter

Viendo 8 entradas - de la 1 a la 8 (de un total de 8)
  • Autor
    Entradas
  • #46452
    Nicolás SeriNicolás Seri
    Participante

    Hola, al querer ejecutar cualquier informe que sea Jasper(Por ejemplo el informe de cobros y pagos) desde las máquinas Clientes, las cuales tienen instalado el cliente liviano da el siguiente error: *Error starting Class org.openXpertya.JasperReport.ReportStarter, NO ASÍ EN EL SERVIDOR. Ejecutando esos mismos informes en el servidor andan bien.
    Alguien me puede dar una mano con esto?

    Gracias.
    Saludos.

    #46453
    José Fantasiajose.geneos
    Participante

    Nico me suena a error de deploy.

    – Volvé a correr el configurar en el servidor.
    – Volvé a levantar el servidor de libertya.
    – Proba descargar el cliente y correr nuevamente el reporte.

    Saludos.

    #46454
    Nicolás SeriNicolás Seri
    Participante

    Hola José, esa solución no me anduvo. La diferencia que encontré entre los reportes jasper que andan y los que no andan es que estos últimos son reportes dinámicos.
    Estos reportes están adjuntos en la definición del informe, pero se ve que las máquinas clientes no lo ven, entonces creo que me está faltando configurar algo para que las maquinas clientes vean esos informes.
    En todas las máquinas clientes uso el cliente liviano. En un par probé descargar el pesado pero sigue sin andar.

    Sigo buscando la solución.
    Gracias por la respuesta. Saludos.

    #49183
    gesges
    Participante

    Hola Nico, te consulto si pudiste encontrar la causa de este error, yo levanté un cliente liviano en una nueva maquina y todo parece funcionar bien salvo un reporte de cheques en cartera que me da ese mensaje, sin embargo en el servidor anda bien.
    Espero puedas responderme, gracias.

    Saludos Gustavo

    #49184
    Jorge MatulichJorge Matulich
    Participante

    Buen día Gustavo, deberías verificar que esten bien definidas las variables de entorno JAVA_HOME y en PATH en la Pc donde ejecutas el cliente liviano y te da ese error.
    La variable JAVA_HOME debe apuntar al path de instalación del JDK.
    Agregar JAVA_HOME a la Variable Path, es IMPORTANTE que el PATH contenga la referencia al directorio de instalación del JDK.

    #49185
    Nicolás SeriNicolás Seri
    Participante

    Hola Gustavo recuerdo que lo solucione, pero no recuerdo como. Y por supuesto no documente. Creo que como dice Jorge lo resolvi acomodando las variables de entorno en las máquinas clientes.

    Saludos.

    #49210
    gesges
    Participante

    Hola Jorge y Nicolás, les comento que fue correcta la solución de la variable de entorno. Muchas gracias y procedo a documentarlo por si vuelve a pasar.

    Saludos y gracias nuevamente.

    #49213
    Federico CristinaFederico Cristina
    Superadministrador

    Buenísimo, gracias por comentarlo!

    Slds!
    Federico

Viendo 8 entradas - de la 1 a la 8 (de un total de 8)
  • Debes estar registrado para responder a este debate.