Error modulo nativo de factura electronica

Inicio Foros Foro principal Instalación y Configuración Error modulo nativo de factura electronica

Viendo 5 entradas - de la 1 a la 5 (de un total de 5)
  • Autor
    Entradas
  • #49220
    AMEBISAMEBIS
    Participante

    Estimados, tengo el siguiente error al crear una factura electronica desde Libertya 19,07. recien instalamos el modulo nativo, antes estabamos con pyafipws y funcionaba.

    Error al registrar la factura. java.lang.Exception: Error al obtener nuevo TA. Certificado no emitido por AC de confianza

    Ese error nos aparece cuando damos completar a la factura.

    Consulta: Tenemos que instalar y setear las variables de entorno de OPENSSL en cada punto de venta donde se emite facturas?
    Que hacemos con la carpeta pyafipws en c:\?

    Saludos

    #49221
    Federico CristinaFederico Cristina
    Superadministrador

    Buenas,

    El error lo está retornando AFIP dado que el certificado no es el esperado. Las causas podrían ser alguna de las siguientes:

    – Se cargó el certificado incorrecto (homo/prod) en la pestaña Punto de Venta Electrónico de la ventana de Configuracion de factura electronica para el punto de venta donde se está intenando emitir
    – Se seleccionó un ambiente incorrecto (homo/prod) en el campo “Ambiente Actual” en la pestaña Punto de Venta Electrónico de la ventana de Configuracion de factura electronica para el punto de venta donde se está intenando emitir

    Efectivamente, la instalación de openssl y variables de entorno debe realizarse en cada punto de venta donde se emitan facturas.

    La carpeta pyafipws ya no es más utilizada desde el momento en que se instala el módulo nativo. Como en todos los casos, se recomienda igualemente realizar una copia de respaldo de la misma.

    Slds!
    Federico

    #49228
    AMEBISAMEBIS
    Participante

    Gracias Federico por responder

    Esta seleccionado en ambos casos como produccion.

    Los certificados estan bien, los estabamos utilizando sin problemas en la version 16,04 con pyafipws.
    El trabajo de instalar plugin se debe realizar en el servidor y tambien en cada equipo.

    Al cargar los certificados en el servidor y darle que los valide me sale el error
    Error en validación certificado homologación: java.lang.Exception: Error al obtener nuevo TA. Certificado no emitido por AC de confianza.

    Cuando entro en la pc que emite facturas electronicas y le doy validar certificados, me sale este error
    Error starting Class org.libertya.locale.ar.electronicInvoice.process.LYEIValidateCRTProcess

    En el servidor tengo instalado OPENSSL para 32 bits, sin embargo es windows 7 64 bits
    En el equipo que emite las facturas electronicas tengo open ssl 64 bits, windows 10 64 bits

    Saludos

    #49233
    Federico CristinaFederico Cristina
    Superadministrador

    Buenas, vamos por partes.

    El trabajo de instalar plugin se debe realizar en el servidor y tambien en cada equipo.

    La instalación del plugin deberá realizarse en el servidor. Sin embargo posteriormente deberás descargarte la nueva versión de Libertya (que contiene los binarios del modulo nativo) desde el servidor hacia la PC que emite facturas, ya sea mediante JNLP (Java Web Start), descargando el cliente pesado. También es posible utilizar el LYWeb del servidor para completar y registrar las facturas electrónicas.

    Al cargar los certificados en el servidor y darle que los valide me sale el error
    Error en validación certificado homologación: java.lang.Exception: Error al obtener nuevo TA. Certificado no emitido por AC de confianza.

    El módulo permite cargar tanto certificados de homologación como de producción, y validarlos independientemente. El error que está indicándote ahí es que el certificado de HOMOLOGACION no es el correcto (quizás porque no lo cargaron o también cargaron el de producción en ese campo), pero respecto del certificado de PRODUCCION no te está indicando error alguno.

    Cuando entro en la pc que emite facturas electronicas y le doy validar certificados, me sale este error
    Error starting Class org.libertya.locale.ar.electronicInvoice.process.LYEIValidateCRTProcess

    Esto es justamente porque los binarios de esa PC no están actualizados. Ver lo que comenté previamente sobre actualizar los binarios de la PC que emite las facturas.

    Slds!

    #55586
    AMEBISAMEBIS
    Participante

    Gracias estimado. Tal como aclaras, lo solucione bajando el cliente pesado desde el servidor, funciona bien.

    El unico tema es que todos los dias hay que validar los certificados para poder emitir la facturacion electronica, pero vamos a seguir probando hasta que quede bien.

    Saludos

Viendo 5 entradas - de la 1 a la 5 (de un total de 5)
  • Debes estar registrado para responder a este debate.