Error en instalación de PostgreSQL

Inicio Foros Foro principal Instalación y Configuración Error en instalación de PostgreSQL

  • Este debate está vacío.
Viendo 2 entradas - de la 1 a la 2 (de un total de 2)
  • Autor
    Entradas
  • #31932
    Abdul Laiseca
    Participante

    Buenas noches.

    Estaba realizando una instalación de Libertya sobre un sistema Windows 7 Ultimante de 32 Bits, con una versión de PosgreSQL 9.1.2-1 y una versión Java JDK 7 Update 1, instalados respectivamente sobre el directorio raíz C: y con el Firewall de Windows desactivado, modifique el archivo pg_hba en la opción host all all 0.0.0.0/0 trust. Desafortunadamente no logre pasar del paso “Opciones para la instalación de PosgreSQL” en el instalador, con molesto letrero de advertencia que decía: “La contraseña que ha ingresado no es correcta para el usuario de base de datos ‘postgres’.

    Adicionalmente comento que probé accediendo desde el pgAdmin 1.14.1 y funciono perfectamente la conexión.

    Cualquier clase de ayuda sera muy bien recibida.

    Atentamente,

    Abdul Laiseca
    Ingeniero de Sistemas en formación
    Universidad Francisco de Paula Santander
    Cúcuta, Colombia

    #36205

    Estimado Abdul,
    Primeramente comentarte que el Stack que estás utilizando: Java 7 y Postgres 9, no han sido testeados con Libertya (esto no quiere decir que no funcione, pero podrías encontrar algún problema). Será interesante tu feedback al respecto si logras configurarlo y probarlo, pero si deseas un entorno “certificado” deberías usar Java 6 y Postgres 8.3.
    Respecto del error, no queda claro si estás utilizando el instalador automatizado o bien el mensaje es al instalar el postgres panualmente. si se trata del instalador automatizado, es posible que éste no esté encontrando el postgres 9 y te haya instalado el 8 y el password que te pide es del 8, que tal vez se haya instalado con otro usuario porque ya existía el usuario “postgres” en el sistema operativo. En ese caso, el usuario debería ser postgres1.
    En todo caso, por la instalación que estás haciendo, te recomiendo realizar el proceso de instalación manual que consiste en cargar el Dump de la base de datos, descomprimir el código binario (o compilarlo) y configurar. Hay mas información en la wiki de libertya.
    Finalmente, te recomiendo que utilices la version 11.10 de Libertya (si no es la que estás usando) que no utiliza PLJava.

    Saludos
    Antonio

Viendo 2 entradas - de la 1 a la 2 (de un total de 2)
  • Debes estar registrado para responder a este debate.