Error directorio java jdk en ubuntu

Inicio Foros Foro principal Instalación y Configuración Error directorio java jdk en ubuntu

Viendo 5 entradas - de la 1 a la 5 (de un total de 5)
  • Autor
    Entradas
  • #33062
    Laura Buffa
    Miembro

    Estoy comprobando la correcta configuracion del servidor en un ubuntu 15 y cuando comprueba aparece el siguiente error:

    Error en el directorio base del Java JDK

    Not found: Java SDK – /usr/lib/jvm/java-6-openjdk-amd64/lib/tools.jar

    Java 6 esta instalado correctamente pero en el directorio no figura la carpeta lib.

    Como se soluciona? Estara java mal instalado?

    Aclaro que el repositorio de java 6 que esta en el instalador es obsoleto, tuve que buscarlo manual.

    Gracias

    #39284
    Laura Buffa
    Miembro

    Les comento para los que se encontraron con este problema que deben descargar el jdk 6 de oracle, bajado de su repositorio de archivos anteriores.

    Es un archivo .bin asi que donde lo dejen ese va a ser su directorio java porque es ahi donde lo instala.

    Les recomiendo que copien el .bin a la carpeta usr/lib/jvm/ para que quede instalado alli.

    Antes es necesario quitar cualquier version openjdk para no tener problemas.

    Una vez instalado, en el direcctorio que les quedo va a ser su JAVA_HOME asi que deben modificar ese parametro en /etc/profile.

    Y con todo esto solucione mi problema con java!

    Saludos

    #39285
    Jose Fantasia
    Miembro

    Te cuento que nosotros tuvimos problemas trabajando con openjdk con lo que pasamos a la versión que esta sugerida que es la oficial de Oracle JDK

    Para instalar cualquier versión primero hay que ejecutar los siguientes commandos:

    sudo apt-get install python-software-properties
    sudo add-apt-repository ppa:webupd8team/java
    sudo apt-get update

    Después, dependiendo de la versión que deseas instalar, ejecuta uno de los siguientes comandos:
    Oracle JDK 6.

    sudo apt-get install oracle-java6-installer

    Con esto no deberías de tener problemas.

    #39287
    Laura Buffa
    Miembro

    Hola, si se que con la version openjdk hay problemas, por eso como explique en mi respuesta hay que descargar la version 6 desde oracle.

    Lo que explicaba es que ya no se puede descargar la version 6 directamente porque la han quitado de circulacion, esta guardada en sus archivos de versiones anteriores.

    Al intentar bajar la aplicacion te advierte que instales la 7 u 8 y la 6 ya no la encuentra.

    Saludos

    #39289
    Jose Fantasia
    Miembro
Viendo 5 entradas - de la 1 a la 5 (de un total de 5)
  • Debes estar registrado para responder a este debate.