Error al trabajar con nuevos puntos de venta

Inicio Foros Foro principal Desarrolladores Error al trabajar con nuevos puntos de venta

Viendo 5 entradas - de la 1 a la 5 (de un total de 5)
  • Autor
    Entradas
  • #31709

    Gente, me parece que hay algo raro en el TPV 10.9…

    Esta pinchando cuando se configuran mas de un punto de venta y se intenta vender en efectivo con algun punto de venta que no sea el 1 (es decir, el que viene creado por defecto…)

    El error que indica es

    ERROR INESPERADO NO SE PUDO REALIZAR EL TICKET
    No es posible completar la operación, El periodo está cerrado.

    Ahora bien… si intentamos hacer la venta con factura manual para ese punto de venta, la venta se completa sin dificultades. Lo que me hace pensar en que el problema es un bug del TPV.

    Adjunto el mensaje del error

    Code:
    ——————————-
    ———–> MPeriod.isOpen: No DocBaseType [16]
    ———–> Msg.getMsg: NOT found: ERROR INESPERADO. No se pudo realizar el ticket [11]
    ———–> Msg.getMsg: NOT found: OXPSYS [11]
    ———–> Msg.getMsg: NOT found: OXPSYS [11]
    ———–> Msg.getMsg: NOT found: Imprimiendo Ticket, Por favor espere [11]
    ===========> MInvoice.set_Value: Column not found – C_Project_ID [17]
    ——————————-
    ===========> MInvoice.get_Value: Column not found – C_Project_ID [17]
    ——————————-
    ===========> MInvoice.get_Value: En Po.Get_value, retornado un nulo [17]
    ——————————-
    ———–> MInvoice.saveUpdate: DocumentNo updated: B000100000005 -> B000100000005 [17]
    ===========> MSequence.getDocumentNo: C_DocType_ID=0 [17]
    ——————————-
    ===========> MSequence.getDocumentNo: C_DocType_ID=0 [17]

    Servidor = servidor : 1099 (No Activo)
    Tunnel=false, Objects=false, Process=false
    Base de datos = servidor : 5432 / libertya1009
    Esquema = libertya
    Usuario = AdminLibertya
    Perfil = Ventas

    Aparentemente no consigue obtener el id del documento de venta nuevo…

    #35535
    Javier Ader
    Participante

    La verdad que no lo chequie; pero verifica que la nueva configuración tenga los tipos de documentos bien seteadas (y si podes hace una verificación a nivel de tabla de base de datos; la ventana de configuración puede que no te este mostrando algun campo que despues usa el TPV; en la nueva configuración probablemente te quede con valor null).

    #35536

    Sigo con problemas. Lo que observé es que en realidad, el problema son los pagos con cheque. Tome una instalación en blanco y configuré varios medios de cobro, y pincha para el de cheque. No veo nada raro en la C_POSPaymentMedium_ID.

    Por lo que veo, no funciona el cobro con cheques en el TPV 10.9

    O me equivoco y alguien le funciona???

    #35540

    Bueno, me equivoqué sobre el origen del problema. Pinchaba porque el tpv estaba configurado para generar Presupuestos. Hay un problema con eso…

    Saludos.

    #35541
Viendo 5 entradas - de la 1 a la 5 (de un total de 5)
  • Debes estar registrado para responder a este debate.