Error al ejecutar ./Configurar.sh

Inicio Foros Foro principal Instalación y Configuración Error al ejecutar ./Configurar.sh

  • Este debate está vacío.
Viendo 9 entradas - de la 1 a la 9 (de un total de 9)
  • Autor
    Entradas
  • #31168
    CARLOS SOTO
    Participante

    Amigos:
    Estoy tratando de instalar Libertya en Ubuntu 9.04, al parecer todo iba bien hasta que ejecuto el archivo ./Configurar y me arroja un error de conexion JDBC, adjunto una captura del error.
    Agradecido.il9lbq.jpg

    #33665
    Federico Cristina
    Superadministrador

    Buenas,

    Según parece el error proviene al chequear la constraseña de superusuario, deberías verificar que la misma esté correctamente especificada (la contraseña de superusuario es la del usuario postgre).

    Corroborá además la configuración del pg_hba.conf a fin de habilitar el correcto acceso a la BBDD.

    Por otra parte, viendo la URL de conexión, pareciera que el nombre de la BBDD especificada es template1. En la captura no puedo visualizar el nombre que especificaste, pero a fin de eliminar posibles problemas, verificá que el nombre especificado en el Configurar.sh corresponda con el nombre de la BBDD generada (generalmente es libertya).

    Suerte!
    Federico

    #33667
    CARLOS SOTO
    Participante

    Hola otra vez:

    He vuelto a revisar los pasos, y no logro hacer que me funcione la instalación, adjunto la captura ahora se ve completa.
    ftm0zn.jpg
    Saludos y gracias.

    #33674
    Federico Cristina
    Superadministrador

    ¿Verificaste los pasos indicados?

    El servidor de base de datos está respondiendo correctamente.

    Lo que te está faltando es indicar ciertos datos en la configuración (fijate que hay campos en blanco), tales como: Nombre de la base de datos y contraseña de superusuario.

    Saludos!

    #33675
    CARLOS SOTO
    Participante

    Hola:

    Gracias por responder, en los campos en blanco he puesto libertya y la password libertya y aún asi no me da el error, verifico los pasos del tutorial de CentOs y no logro hacer funcionar libertya.
    Alguna pista?
    Gracias

    #33684
    Federico Cristina
    Superadministrador

    Buenas,

    Una vez corregido estos dos valores, el mensaje de error debería ser diferente, ya que estaría encontrando correctamente la base de datos.
    No es necesario enviar una nueva captura, pero por favor verificá si al menos el mensaje de error cambió (ese ya sería un paso).

    A fin de eliminar posibles problemas de acceso, verificá tu configuración de pg_hba.conf. Este archivo se encuentra dentro de la instalación de postgres (por ejemplo: /usr/local/pgsql/data/). La manera más facil es dar todo tipo de acceso desde cualquier host, indicando metodo trust para todo rango de IP, algo así:

    Code:
    # TYPE DATABASE USER CIDR-ADDRESS METHOD

    # “local” is for Unix domain socket connections only
    local all all trust
    # IPv4 local connections:
    host all all 127.0.0.1/32 trust
    # IPv6 local connections:
    host all all ::1/128 trust
    host all all 192.168.3.0/24 trust
    # host all all 192.168.2.0/24 trust

    Suerte!
    Federico

    #33666
    Gustavo Borchez
    Participante

    Federico:

    Tengo el mismo problema…

    Me tira error en el chequeo de la contraseña de superusuario.

    Tengo configurado el pg_hba.conf como mostraste, pero eso no soluciona…

    Cambie la contraseña desde el pgAdmin y tampoco.

    Puse la contraseña de root y tampoco.

    El servidor de bases de datos est{a corriendo y accedo a la db por el pgAdmin sin problemas.

    #33691
    Federico Cristina
    Superadministrador

    Buenas,

    Por favor, verifiquen en el archivo postgresql.conf (dentro del directorio data de psql), las IPs de las que podrá escuchar.

    El valor por defecto es localhost, el cual es usado por ejemplo desde el pgAdmin para la conexión, pero desde el Configurar.sh esto no es así, ya que no trabaja con acceso mediante localhost, sino mediante hostname o IP.

    Es por esto que deberían modificar la propiedad listen_addres a * (escuchar desde cualquier IP).

    Code:
    #—————————————————————————
    # CONNECTIONS AND AUTHENTICATION
    #—————————————————————————

    # – Connection Settings –

    listen_addresses = ‘*’

    # what IP address(es) to listen on;
    # comma-separated list of addresses;
    # defaults to ‘localhost’, ‘*’ = all
    # (change requires restart)

    Recuerden reiniciar el postgres para que tome los cambios!

    Saludos,
    Federico

    #33685

    Lo resolví poniendo en el archivo pg_hba.conf en la ip 0.0.0.0/0 no es lo óptimo pero bue ya me tenia cansado…

Viendo 9 entradas - de la 1 a la 9 (de un total de 9)
  • Debes estar registrado para responder a este debate.