Error al actualizar BD de 10.03 a 10.09

Inicio Foros Foro principal Instalación y Configuración Error al actualizar BD de 10.03 a 10.09

  • Este debate está vacío.
Viendo 4 entradas - de la 1 a la 4 (de un total de 4)
  • Autor
    Entradas
  • #31624

    Al iniciar la instalación de

    /ServidorOXP/org.libertya.core.upgrade_10.03-10.09.jar

    en la ventana de Instalación de Componentes y plugins se produce el siguiente error:

    === Instalando Componente y Version. Registrando Plugin === === Ejecutando sentencias de preinstalacion === Error al realizar la instalación: ERROR: no hay restricción unique que coincida con las columnas dadas en la tabla referida «ad_electronicinvoiceformat»

    Alguna pista?
    Gracias.

    #35307
    Federico Cristina
    Superadministrador

    Buenas,

    Por favor, fijate si está relacionado con este thread.

    Que versión de PostgreSQL estás usando?

    Saludos,
    Federico

    #35308

    Tengo la versión 8.3.10

    Logré que lanzara la actualización pero luego de unos minutos arroja el siguiente error:

    No existe el lenguaje < plpgsql >

    Como puedo solucionar esto?

    Gracias!

    #35340
    Federico Cristina
    Superadministrador

    Ese error es porque no tenés instalado plpgsql, lo cual me parece raro si es que estás utilizando Libertya normalmente. En caso de que efectivamente no hayas tenido instalado plpgsql, te van a faltar varias funciones de Libertya. Antes de realizar cualquier actualización, primeramente deberías verificar ésto.

    Saludos,
    Federico

Viendo 4 entradas - de la 1 a la 4 (de un total de 4)
  • Debes estar registrado para responder a este debate.