¿Documentación para Instalación en GNU/Linux?

Inicio Foros Foro principal Instalación y Configuración ¿Documentación para Instalación en GNU/Linux?

Viendo 4 entradas - de la 1 a la 4 (de un total de 4)
  • Autor
    Entradas
  • #48894
    libertyaCLlibertyaCL
    Participante

    Hola,

    Buscando para instalar Libertya me encuentro con el hecho de que la única documentación disponible es de 2015.
    ¿No existe documentación actualizada para poder instalar en la actualidad?
    Gracias
    Saludos

    #48895
    Federico CristinaFederico Cristina
    Superadministrador

    Buenas,

    En realidad los pasos de instalación son prácticamente los mismos. Lo que puede llegar a cambiar es el stack de tecnologías de soporte y sus versiones.

    Actualmente libertya requiere Oracle Java entre las versiones 6 y 8, y postgres entre las versiones 8.4 y 9.5. Si bien puede funcionar con versiones más recientes, todavía no se ha verificado.

    Luego el resto de pasos son siempre los mismos: restaurar la base de datos, deployar el ServidorOXP.zip y configurar tal como indica en la documentación.

    Adicionalmente, tené en cuenta que contás con una máquina virtual para VirtualBox (cuyo sistema operativo es Ubuntu) en donde podés realizar cualquier tipo de prueba y verificación del ERP).

    Saludos,
    Federico

    Si querés profundizar sobre cualquiera de estos temas, te invitamos a las sesiones semanales gratuitas de Consultoría On Line.
    Más información en https://www.libertya.org/forums/topic/documentacion-completa-y-soporte-libre-para-libertya-pyme-3/

    #48904
    libertyaCLlibertyaCL
    Participante

    Hola, gracias por responder.

    Se intentó instalar, pero aún siendo versiones antiguas de distros (como Devuan, basada en Debian 9) ya traen la versión 9.6 de postgresql y no se puede instalar.

    No hay alguna versión con algún contenedor (como docker) para poder correr Libertya en entornos que no sean antiguos, ¿no?

    Saludos

    #48910
    Federico CristinaFederico Cristina
    Superadministrador

    Buenas,

    Por experiencia, la forma más sencilla de instalar cualquier versión de Postgres es simplemente descargar los fuentes y compilarlos. En el tar de los fuentes hay un archivo INSTALL que indica de manera sencilla el paso a paso. Puede ser que se requieran instalar librerías adicionales (gcc, zlib, etc), pero no pasa más de ahí la complejidad.

    Por otra parte, si bien no contamos con un docker, podrías probar con la máquina virtual para VirtualBox que te mencionaba previamente.

    Saludos!
    Federico

Viendo 4 entradas - de la 1 a la 4 (de un total de 4)
  • Debes estar registrado para responder a este debate.