Consulta modificacion reportes

Inicio Foros Foro principal Ayuda Consulta modificacion reportes

  • Este debate está vacío.
Viendo 7 entradas - de la 1 a la 7 (de un total de 7)
  • Autor
    Entradas
  • #32397
    Javier Loffredo
    Participante

    Buenas, quería saber que versión de iReport tengo que usar a la hora de modificar un reporte en libertya 13.01?

    En esta caso particular es para agregar un texto fijo a las facturas.

    Gracias!!

    #37553
    AMEBIS
    Participante

    i-report 2.0

    Saludos

    #37554
    Javier Loffredo
    Participante

    ok, gracias. funcionaría con ireport 2.0.2 (es lo mas atrás que me permite volver el ireport como versiones anteriores).

    para subir la modificación es poniendo el reporte compilado (.jasper) en la parte de binario del reporte que quiero modificar, no?

    #37557
    AMEBIS
    Participante

    Hola, si funciona con ireport 2.0.2 incluso yo tengo ese.

    Para subir la modificación tenes que compilar el archivo y te va a generar un archivo .jasper, ese mismo lo tenes que subir en la ventana jasper reports de “configuración de la compañía” en el campo de arriba, osea el que no esta en blanco (no me acuerdo bien), por las dudas subilos en los dos para evitar confusiones.

    Si estas ejecutando ireport en linux, cuando lo compiles te crea el .jasper en la carpeta del ireport /bin … fijate bien. por las dudas.

    Saludos

    #37555
    Javier Loffredo
    Participante

    Muchas gracias, funcionó perfecto.
    Ahora el problema que tengo es que después de subir el reporte modificado (solo agregué un campo de texto estático) cuando hago una factura no me muestra los items de la misma (si todos los demás datos)

    A que se puede deber eso?

    #37560
    Javier Loffredo
    Participante

    Compile y subi el del codigo fuente de libertya 13 y sigue sin mostrarme el detalle de la factura. es algo comun eso?
    Adjunto el archivo que use para compilar.
    http://www.mediafire.com/?4g2kud4ebcse64n

    #37563
    Federico Cristina
    Superadministrador

    Buenas,

    Quizás el problema que se te presenta es el siguiente: en muchos casos la tipografía es demasiado grande para el espacio definido en los fields (las “cajitas” que las contienen). Probá a reducir la tipografía a ver si podés observar los resultados.

    Bueno, eso en caso que hayas realizado modificaciones sobre dichos campos.

    Saludos,
    Federico

Viendo 7 entradas - de la 1 a la 7 (de un total de 7)
  • Debes estar registrado para responder a este debate.