Conflicto de versión

Inicio Foros Foro principal Instalación y Configuración Conflicto de versión

  • Este debate está vacío.
Viendo 9 entradas - de la 1 a la 9 (de un total de 9)
  • Autor
    Entradas
  • #31165
    Daniel Blanco
    Miembro

    – Actualicé el oxp.jar grabandolo en servidoroxplib tal como me indicaran en el curso.

    Luego corrí el sql actualizando la version:

    update libertya.ad_system set version = ’26-10-2009′

    (obtuve un “successful”).

    Obtengo una pantalla como la de la figura, que me dice que hay conflicto entre versiones.

    Luego de esto, probé bajar el archivo ServidorOXP_V09.10.zip y aplicarlo a la carpeta correspondiente.

    Sigo teniendo el mismo problema… qué otro archivo faltaría? [img size=312]https://www.libertya.org/media/kunena/attachments/legacy/images/version_lib.JPG[/img]

    #33659
    Federico Cristina
    Superadministrador

    Buenas,

    Por favor, probá a invocar al Configurar.sh (o Configurar.bat) del directorio ServidorOXP. Sin hacer ningún cambio en dicha ventana, guardá la configuración. De esta manera el nuevo oxp.jar debería propagarse correctamente.

    Saludos,
    Federico

    #33660
    Sergio Daniel Gómez
    Participante

    Hola, tengo el mismo inconveniente, probé con lo recomendado pero no se resolvió el problema.
    No me preocupa tanto ya que no contiene datos reales por lo que puedo reinstalar Libertya, no así postgres.
    Es decir, de no haber otra opción desinstalo Libertya 9.07 (necesitaría que me indiquen cómo) e instalaría la version 9.10.
    Desde ya muchas gracias.
    Saludos.

    #33682

    Sergio / Daniel,
    Al parecer el update ha funcionado a nivel de la base de datos, pero no se está ejecutando el jar actualizado, por lo que el código tiene una versión mas vieja que lo que indica la base de datos.
    Lo que no indican en ningun caso es si esto se produce en los equipos “clientes” o si ejecutando el Libertya.exe (o .sh) en el mismo server también da el error. Si es lo 1ero y no lo 2do, se trata de un problema con el mecanismo de actualización del JavaWebStart (si es que lo estan utilizando) . Lo que deberían hacer es ingresar en la aplicacion de JavaWebStart y eliminar la aplicación Libertya para que la descargue nuevamente.
    Si instalaron los clientes desde el zip que se descarga del server, deberían volver a copiarlo y volver a intentar.
    Si el problema se presenta también a nivel de servidor (es decir: levantando EN el servidor el cliente java) entonces habría que verificar que realmente se haya sobreescrito el sistema. Una posibilidad es renombrar la vieja carpeta ServidorOXP y crear una nueva con la nueva version.

    Espero serles de utilidad.
    Saludos
    Antonio.

    #33683
    Sergio Daniel Gómez
    Participante

    Comento que tanto en los clientes (probado en 3) como en el servidor ocurría lo mismo, por lo que opté por bajar la actualización nuevamente y rehacer el proceso de actualización. Sin suerte… el problema continuó.
    Segunda opción: Utilizar la carpeta ServidorOXP de la actualización, poniéndola en / (raíz del disco, la anterior estaba en otra ruta). Seguido, correr Configurar.sh e IniciarServidor.sh.
    Con eso, en el primer cliente la descarga decía ser 9.07, sin embargo se ejecutó sin problemas. En el caso del servidor, mostró directamente v9.10.
    Con lo cual, de mi parte, finalizado el tema. Aunque quedo con la duda…
    Gracias.

    #33696
    Luis Castelat
    Miembro

    Federico como estas:

    Nosotros tambien tenemos problemas para actualizar de la version 09.07 a la 09.10, nos da el mismo error en el cliente y en el servidor. Los pasos que hicimos fue sobreescribir la nueva version en el servidor, y ejecutar el script de actualización libertyaUpdater_0907_0910, y se hizo correctamente. Tambien luego de esto ejecutamos configurar.exe. En el servidor nos figura que cambio ya de version 09.10 pero al momento de elegir el perfil para entrar solo lo hace en el de Ventas en los demás larga el error Conflicto de Version comentado en los post anteriores.

    Quisiera saber si hay alguna otra opcion para arreglar ese error. Pensaba en instalar la nueva version completa, desintalando la anterior y restaurar la BD que tengo con la version anterior desde el pgadmin y luego ejecutar el script de actualizacion.

    Espero tus comentarios.

    Saludos!!!!!!!!!!!

    #33760

    El error de conflicto de version SOLO indica que el numero de version que existe en el diccionario (es decir a nivel base de datos) NO es el mismo que la que está en el código utilizado (mas alla de que esto produzca otros problemas, el control se basa en esa condicion.

    Hay solo dos posibles causas:
    1) El codigo no esta actualizado y la DB si
    2) El Codigo esta actualizado y la DB no.

    Si estás seguro que el codigo está actualizado, entonces la falla está en la DB.
    Entonces, lo que esta pasando es que el script: libertyaUpdater_0907_0910 esta fallando por mas que no de error.
    Recomiendo verificar si la base de datos a la que se conecta el Script es la misma que la que estan utilizando (si hubiera mas de una, cosa que es posible) y la otra es verificar la tabla: ad_system que debería tener la versión: “26-10-2009”
    Si la version en la tabla es la correcta, entonces el codigo NO esta actualizado. Lo mejor es mover la carpeta ServidorOXP completa y descargarse la nueva, ejecutar el Condigurar.exe|.sh y apuntar a la base de datos.
    Suerte!
    Antonio

    #33761
    Gustavo Borchez
    Participante

    Yo lo solucioné modificando DATE_VERSION y DB_VERSION en openXpertya.java y recompilando.

    y ahora pregunto: Si reemplazan el ejecutable por el que está comprimido en la nueva versión ¿no funcionaría? (renombren por las dudas antes de pisar el archivo para poder volver para atrás…)

    #33765

    Eso justamente es lo que se debe hacer.

    El update consiste en:
    1) Actualizar la DB (esto lo hace el Updater)
    2) Actualizar TODO el código a la ultima version.(esto hay que hacerlo a amano)

    Si lo cambiaste a mano quiere decir que no tenés la ultima versión del código. Por favor descargate la ultima versión de los fuentes ya que hay mas cambios que solo el Nro de versión en el codigo.

Viendo 9 entradas - de la 1 a la 9 (de un total de 9)
  • Debes estar registrado para responder a este debate.