Configurar.exe y Falta Main Class

Inicio Foros Foro principal Instalación y Configuración Configurar.exe y Falta Main Class

Viendo 8 entradas - de la 1 a la 8 (de un total de 8)
  • Autor
    Entradas
  • #46637
    Joel CastañoJoel Castaño
    Participante

    Buenas tardes, tenía una instalación funcionando correctamente sobre XP.

    Intente acceder desde otra PC, utilizando IP:8080 pero no accedía…. me di cuenta que no levantaba el servidor, pero no me deja ver el error porque se cierra rapido la pantalla de DOS.

    Entonces, fui a la carpeta SERVIDOROXP y ejecute el configurar.exe, y solo toque un path y guardé.

    Ahora tampoco me funciona la instalación original, me dice:

    Java Virtual Machine Launcher : Could not find the main class: org.openXpertya.OpenXpertya. Program will exit.

    Que puedo hacer????

    Gracias.

    #46638
    Luis Alberto TobaLuis Alberto Toba
    Participante

    Joel, nos a pasado que en ocaciones si el proceso Configurar no concluye correctamente se da este inconveniente.
    Una solución es descargar el ServidorOXP.zip y sobre escribir los archivos en el servidor, fíjate de realizar un backup si tenes componentes de personalización dentro de la carpeta /lib/plugins.
    Luego volve a ejecutar el Configurar.exe y ya tendría que quedar funcinando.

    Saludos

    #46640
    Joel CastañoJoel Castaño
    Participante

    Perdón mi ignorancia, pero desde donde descargo el ServidorOXP.zip?

    Y con respecto a la personalización, lo unico que tengo cargado son datos de configuración y algunos datos maestros… es necesario que los backupee?

    Mil gracias.

    Joel

    #46641
    Luis Alberto TobaLuis Alberto Toba
    Participante

    Joel, el ServidorOXP.zip lo podes descargar de la sección de descargas de la pagina: https://www.libertya.org/descargas/
    Seleccionando la versión que necesitas en la parte de instalación completa multiplataforma.
    También podes descargarlo de sourceforge, la ultima versión por ejemplo:
    https://sourceforge.net/projects/libertya/files/libertya/release/1705/multi-platform/

    Con respecto a los componentes solo necesitas realizar el backup si tenes ampliaciones a la lógica estándar de Libertya, lo que entiendo no es tu caso.
    Solo tenes que sobre escribir los archivos del programa que están dentro del zip, no modificar nada en la base de datos por lo que no necesitarías realizar copia de seguridad.
    No obstante esto siempre es bueno, antes de realizar ninguna tarea que tengas un backup de la base de datos.

    Saludos

    #46642
    Joel CastañoJoel Castaño
    Participante

    Bueno, ya lo logré reponer!!! Muchas gracias!!!!

    Ahora parto desde cero de nuevo….

    Necesito accederlo desde otra PC en red, según entiendo el Servidor debe estar corriendo no?

    Cuando le doy al bat de “iniciar servidor” sale un pantallazo rápido de DOS y no me deja ver nada…

    Cómo sigo???

    Gracias.

    Joel

    #46643
    Luis Alberto TobaLuis Alberto Toba
    Participante

    Joel, efectivamente para acceder desde otra maquina necesitas levantar el servidor de aplicaciones para descargar el cliente en la otra pc.
    Con respecto al error, se me ocurre que podes intentar correr desde la linea de comando, cmd.exe, el IniciarServidor.bat para ver si podes ver cual es el error.
    Por otro lado, algunos puntos a tener en cuenta que podes revisar.
    1- Tener las variables de entorno JAVA_HOME y OXP_HOME correctamente configuradas.
    2- Correr el Configurar.exe para verificar que todo este correcto
    3- Si el Windows es de 64bits, y el Java instalado de 32 en algunos casos genera inconvenientes por el path de acceso, en este caso tendrías que reinstalar java y volver a configurar la variable JAVA_HOME.

    Esto es lo que se me ocurre sin mas información sobre el problema.

    Saludos

    #46644
    Joel CastañoJoel Castaño
    Participante

    Hola! Muchas gracias desde ya por todas tus respuestas!

    El IniciarServidor.bat, por mas que lo ejecute desde la linea de comandos, no funciona, hasta se me cierra la ventana del CMD!!!

    Increible… y no me da tiempo a leer nada, pero no displaya tanto como en otras instalaciones que tengo…son 3 o 4 renglones nomas…

    Hay que algún lado que se pueda ver el log de error de eso?

    O hay alguna forma de instalar solamente el servidor de nuevo???

    Mil gracias.!!!!

    Joel

    #46650
    Luis Alberto TobaLuis Alberto Toba
    Participante

    Seguramente tenes alguna problema en alguna configuración. Pudiste correr el Configurar.exe?

    Si no recuerdo mal hay una forma de evitar que el cmd no se cierre al encontrar un error, creo que ejecutándolo como cmd.exe /k

    Saludos

Viendo 8 entradas - de la 1 a la 8 (de un total de 8)
  • Debes estar registrado para responder a este debate.