Compilar con Eclipse

Inicio Foros Foro principal Desarrolladores Compilar con Eclipse

  • Este debate está vacío.
Viendo 6 entradas - de la 1 a la 6 (de un total de 6)
  • Autor
    Entradas
  • #31180
    Dario Esca
    Participante

    Buenas a todos.
    Estoy teniendo un problema al configurar los fuentes para compilar con Eclipse.
    El tema es el siguiente; sigo al pie de la letra la guia “Como compilar con Eclipse los fuentes de Libertya” y me encuentro con que al momento de ejecutar “ant” en la carpeta “c:libertya_srcIzPacksrc” sale un mensaje diciento “No se esperaba de en este momento” (asi textualmente) y esta demas decir que no se crea installer.jar.
    Desde ya agradezco la ayuda que me puedan brindar.

    #33702
    Federico Cristina
    Superadministrador

    Buenas,

    Las indicaciones para la compilación en Eclipse que comentás se encuentran algo desactualizadas (fijate que todavía referencia a JDK 1.5, cuando LY actualmente requiere JDK 1.6).

    Actualmente es mucho más sencillo incorporar y compilar el proyecto en Eclipse: simplemente hay que descargar los fuentes en – por ejemplo – c:libertya. Luego desde el Eclipse accedes a File -> New -> Java Project
    y en la ventana de diálogo seleccionás “Create from existing project” y seleccionas el directorio c:libertya. Eclipse leerá toda la configuración y ordenará el classpath según corresponda.

    Tenes que contemplar sin embargo algunas cosas:

    1) Contempla el uso de Eclipse Galileo
    2) Requiere JDK 1.6
    3) Hay que especificar el proyecto como codificación UTF8

    Saludos!
    Federico

    #33705
    Federico Cristina
    Superadministrador

    Ya se encuentra actualizado el artículo de la wiki correspondiente.

    Saludos,
    Federico

    #33726
    Dario Esca
    Participante

    Federico:

    Gracias por tu ayuda, pude incorporar los fuentes a Eclipse pero me salen 11393 warnings y todos ellos dicen “ArrayList is a raw type. References to generic type ArrayList should be parametrized.” por ejemplo en ADMap.java line 209 y asi en varios modulos.

    Desde ya agradezco tu ayuda como siempre. Gracias.

    Saludos!.

    #33727
    Federico Cristina
    Superadministrador

    Buenas,

    Es correcto que se presenten warnings que mencionás. Siempre y cuando los mismos no sean errores, vas a poder iniciar correctamente la aplicación.

    El origen de los mismos se deben a que LY es un proyecto muy grande, con miles de líneas de código, y que evoluciona en el tiempo. Hay muchos warnings relacionados con deprecations, otros con imports actualmente no utilizados, tipos en colecciones (como el que indicás) que en jdk 1.4 no se requerían, etc.

    Que todos los warnings indiquen el mismo mensaje seguramente se deba al criterio de ordenamiento de los mismos, en conjunto con las reglas de filtrado.

    Saludos,
    Federico

    #33728
    Dario Esca
    Participante

    Gracias Federico, has sido muy amable como siempre.

Viendo 6 entradas - de la 1 a la 6 (de un total de 6)
  • Debes estar registrado para responder a este debate.