Cliente liviano / pesado (uno sí el otrono)

Inicio Foros Foro principal Instalación y Configuración Cliente liviano / pesado (uno sí el otrono)

  • Este debate está vacío.
Viendo 6 entradas - de la 1 a la 6 (de un total de 6)
  • Autor
    Entradas
  • #31181
    Carranza Carlos
    Participante

    He instalado Libertya en una máquina virtual (virtualbox)con Ubuntu 9.04 server, luego de varias idas y vueltas.
    Desde el mismo servidor (le tuve que poner una interface liviana para poder correr el Configurar.sh) funciona perfectamente (importante cuando se configura poner la ip del servidor y no el nombre del mismo).
    Desde la máquina Host (WXP) intenté correr la aplicación (antes de poner la ip en Configurar.sh no andaba nada) y funciona sólo el cliente pesado. El liviano presenta la siguiente pantalla de error con sus pestañas adjuntas.

    #33703

    Por favor poesta nuevamente la imagen que no se ve.o al menos el mensaje de error.
    Respecto de la IP o el nombre, si pones el nombre, tenés que asegurarte que desde la PC cliente el nombre resuelva correctamente ya que sino, no accederá. En redes Win el nombre de la PC se resuelve , pero si el linux no tiene SMB activado, la PC Linux no publica su nombre.

    #33704
    Carranza Carlos
    Participante

    Al final no pude poner los mensajes, ya que preparé un documento, pero no me lo dejó adjuntar (sólo imágenes).
    Así que ahora coloco la información desde el portapapeles

    Al querer ejecutar la aplicación desde la página web de mi servidor, comienza la descarga y al cabo de 10 seg. presenta un mensaje de error.
    “No se puede iniciar la aplicación”
    Tiene un botón de detalles, el cual al presionarlo se abre una nueva ventana, con pestañas : Archivo de ejecución y Excepción

    El error es : Error : Connection refused: connect

    En la pestaña Archivo de ejecución presenta la siguiente información :

    cliente libertya v09.10 DISYTEL Libertya, Software Libre de Gestion Libertya Libertya, Software Libre de Gestion Libertya Software Libre de Gestion

    y la pestaña Excepción presenta la siguiente información :

    java.net.ConnectException: Connection refused: connect
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(Unknown Source)
    at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
    at java.net.PlainSocketImpl.connect(Unknown Source)
    at java.net.SocksSocketImpl.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at sun.net.NetworkClient.doConnect(Unknown Source)
    at sun.net.www.http.HttpClient.openServer(Unknown Source)
    at sun.net.www.http.HttpClient.openServer(Unknown Source)
    at sun.net.www.http.HttpClient.(Unknown Source)
    at sun.net.www.http.HttpClient.New(Unknown Source)
    at sun.net.www.http.HttpClient.New(Unknown Source)
    at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source)
    at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)
    at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source)
    at com.sun.deploy.net.BasicHttpRequest.doRequest(Unknown Source)
    at com.sun.deploy.net.BasicHttpRequest.doGetRequestEX(Unknown Source)
    at com.sun.deploy.net.DownloadEngine.isUpdateAvailable(Unknown Source)
    at com.sun.deploy.net.DownloadEngine.isUpdateAvailable(Unknown Source)
    at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(Unknown Source)
    at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(Unknown Source)
    at com.sun.deploy.net.DownloadEngine.getResource(Unknown Source)
    at com.sun.javaws.LaunchDownload.downloadJarFiles(Unknown Source)
    at com.sun.javaws.LaunchDownload.downloadEagerorAll(Unknown Source)
    at com.sun.javaws.Launcher.downloadResources(Unknown Source)
    at com.sun.javaws.Launcher.prepareLaunchFile(Unknown Source)
    at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
    at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
    at com.sun.javaws.Launcher.launch(Unknown Source)
    at com.sun.javaws.Main.launchApp(Unknown Source)
    at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
    at com.sun.javaws.Main$1.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)

    Espero que con esto alcance, ya que es toda la info que tengo.

    #33708
    Federico Cristina
    Superadministrador

    Buenas,

    Es difícil determinar el origen del problema en este caso. Sin embargo, a fin de reducir las posibilidades, te sugeriría que pruebes a limpiar los archivos y aplicaciones temporales de java que tengas (dicha funcionalidad la encontrás en Panel de Control -> Java).

    Por otra parte, verificá que en el WXP también tengas instalado java 1.6.

    Saludos!

    #33711
    Carranza Carlos
    Participante

    Estimado, las versiones de java son las mismas en el servidor y en el cliente, aunque debo decir que en el cliente, antes, tenía otra.
    Primero verifiqué los clientes java y luego procedí a limpiar el cliente XP.
    Luego de limpiar los archivos temporales el problema quedó perfectamente solucionado.
    Muchas gracias.

    Cómo se marca el hilo para indicar que ha sido solucionado?

    #33712
    Federico Cristina
    Superadministrador

    Me alegro que hayas podido solucionar tu problema!

    Ya estoy marcando el thread como solucionado.

    Saludos,
    Federico

Viendo 6 entradas - de la 1 a la 6 (de un total de 6)
  • El debate ‘Cliente liviano / pesado (uno sí el otrono)’ está cerrado y no admite más respuestas.