Certificados vencidos Factura Electronica

Inicio Foros Foro principal Instalación y Configuración Certificados vencidos Factura Electronica

Viendo 7 entradas - de la 1 a la 7 (de un total de 7)
  • Autor
    Entradas
  • #46431
    AMEBISAMEBIS
    Participante

    Estimados. Tengo la siguiente situacion:

    – Se vencieron los certificados de Libertya FAE, cuando genere nuevos certificados me sale que tienen que ser de 2048 bits, lo hice con OPENSSL y AFIP lo tomo sin problemas, generando así el archivo .csr perfectamente.
    – Cuando lo reemplace en pyafipws me topé con que cambiaron todo y ahora se utiliza Python 2.7
    – La instalacion que tenia antes era en una PC con windows 7 64 bits y estoy seguro que todas las aplicaciones eran de 32 bits.
    – Consulta, alguien tiene los programas nuevos que tenemos que instalar para que funcione perfectmente FAE con los nuevos certificados, estuve chequeando el documento nuevo que subieron a la web de Libertya, pero no esta claro y hay muchas mas aplicaciones de las que se utilizaban antes.

    -Estoy dispuesto a crear un tutorial o manual paso a paso siempre y cuando alguien me ayude con los instaladores que hay que utilizar para que funcione correctamente.

    Saludos

    #46432
    Federico De TittaFederico De Titta
    Participante

    Hola te paso los instaladores que use.
    Fijate que para 64bit hay dos instaladores repetidos en diferente versión del python (python-2.7.12.amd64 y python-2.7.13rc1.amd64). No me acuerdo cual era que instale, pero proba primero con la 2.7.12 y si no con la 2.7.13rC1.

    Phyton 2.7 32 bits
    Phyton 2.7 64 bits

    Yo fui instalando todo directamente desde los ejecutables. Espero que te sirva.

    Saludos
    Federico

    #46433
    AMEBISAMEBIS
    Participante

    Gracias por la ayuda. Una consulta, el sistema operativo es de 64 bits, pero libertya y todas las aplicaciones relacionadas a FAE son de 32 Bits, entonces hay que instalar todo en 32 bits o vos instalaste las de 64 bits?

    Por defecto libertya esta en 32 bits, salvo java lo demas es de 32 btis.

    Saludos

    #46434
    Federico De TittaFederico De Titta
    Participante

    Te digo la verdad, no estoy seguro si el de 32 bits te funciona en un sistema operativo de 64 bits.
    Con respecto a libertya creo que hay un solo instalador para windows, que lo he probado y funciona tanto en 32 como en 64 bits.

    Phyton es una instalación totalmente aparte de libertya, yo instalaría la versión que corresponde a tu sistema operativo o sea en tu caso 64 bits.

    Saludos

    #46436
    AMEBISAMEBIS
    Participante

    Gracias, acabo de probar con la version de 32 bits y no funciono. Lo unico que falto subir es el archivo pyafipws.zip

    El que baje de la pagina de libertya no esta completo, le faltan varios archivos. Lo tenes a eso por casualidad?

    Saludos

    #46437
    Federico De TittaFederico De Titta
    Participante

    Yo seguí los pasos del instructivo que esta subido acá en el foro.

    IMPORTANTE:Renovación de certificados SSL utilizados por los Webservices de AFIP

    El pyafipws.zip lo descargue del link que figura en el PDF al igual que las versiones nuevas del Phyton y funciona todo bien.

    Saludos

    #46438
    AMEBISAMEBIS
    Participante

    Gracias Federico. me funciono a la perfeccion.

    El problema que estoy teniendo en otra empresa es que a la hora de emitir una factura con percepciones e IIBB provinciales el sistema esta juntando todos los impuestos como IVA y AFIP me devuelve el siguiente error.

    La suma de los campos Importe en IVA debe ser igual al valor ingresado en ImpIVA.

    Cuando la factura no tiene TEM ni IIBB (impuestos municipales y provinciales) entonces no hay problemas, el problema es cuando si tiene. Alguien sabe donde puedo tocar este tema?
    Saludos

Viendo 7 entradas - de la 1 a la 7 (de un total de 7)
  • Debes estar registrado para responder a este debate.