Backup y restore

Inicio Foros Foro principal Instalación y Configuración Backup y restore

Viendo 3 entradas - de la 1 a la 3 (de un total de 3)
  • Autor
    Entradas
  • #32352
    Alfredo Lisjak
    Participante

    Hola!! Les comento que tengo instalado libertya 10.03 en windows xp y estoy tratando de realizar un backup y restore de la base datos en otra pc con la versión 13.01 de libertya y windows 7.
    Siguiendo la wiki para realizar estas operaciones, mi pregunta es cómo puedo verificar que la restauracíon halla salido bien? ¿Existe algún archivo de log dónde pueda verificarlo? Particularmente en el paso siguiente:

    Estando ubicado en: (C:Program filesPostgreSQL8.3bin)

    psql -f C:libertya.sql -d bdnueva libertya

    dónde:

    bdnueva, la cree con:

    createdb -U libertya -O libertya -E UTF8 bdnueva

    Muchas gracias…

    Alfredo

    #37401
    Carranza Carlos
    Participante

    Hola, el comando estaría, en principio bien.
    Lo que no está bien es llevar una base de 10.03 a una instalación de 13.01. No te va a funcionar si no hacés todas las migraciones de las versiones entremedio.
    Entre otras cosas, estas migraciones agregan artículso que permiten manejar las retensiones (lo que más rápido me acuerdo).
    Para hacer las migraciones, también debes recordar que, recién la versión 11.10 no necesitaba pljava.
    Deberías partir de una instalación 10.03, migrar a 10.09, de allí a 11.10 y finalmente a 13.01, y el resultado del backup, después de haber terminado todo, lo restaurás donde querías (por supuesto que todo esto es para mantener los datos originales).
    Si además, tenías modificaciones en el código deberás probar que esto siga funcionando o que el sistema funcione como lo tenías customizado en tu 10.03. Si estabas con la versión sin tocar, por lo menos deberías leer los changelog, porque en el camino algo podría haber cambiado (por ej. los límites de crédito en las entidades comerciales).
    Volviendo al backup y restore, si el restore (que es de postgresql) termina bien es que se crearon las tablas y cargaron los datos correctamente.

    #37402
    Alfredo Lisjak
    Participante

    Muchas gracias…

Viendo 3 entradas - de la 1 a la 3 (de un total de 3)
  • Debes estar registrado para responder a este debate.