Ayuda!! Postgres 8.3 con última versión de Ubuntu

Inicio Foros Foro principal Instalación y Configuración Ayuda!! Postgres 8.3 con última versión de Ubuntu

  • Este debate está vacío.
Viendo 7 entradas - de la 1 a la 7 (de un total de 7)
  • Autor
    Entradas
  • #31508

    Gente, una consulta…

    Alguien sabe de donde puedo descargarme los paquetes de instalación de Postgres 8.3 para Ubuntu?

    Los que querramos trabajar con Libertya sobre Ubuntu 10 tenemos un problema.

    No es posible instalar Postgres 8.3 como indican los manuales del foro, ya que parecieran no estar mas disponibles desde los repositorios. Solo puedo instalarme la 8.4. Habría que encontrar un lugar donde descargar los .deb del postgres 8.3.

    Sería posible habilitar una descarga de los mismos en el site de Libertya/Descargas? al menos hasta que quede estable el pl/java sobre la 8.4 para linux.

    #34917
    Javier Ader
    Participante

    Hace rato que no manejo Ubuntu… pero bueno, https://launchpad.net/ubuntu/lucid/i386/postgresql-8.3/8.3.8-1 ahi parecen haber paquetes binarios para tu Lucid. Son .deb y muy bien no recuerdo como se instalaban, pero deberían andar.

    Ahora, alguien ya no habia hecho andar libertya usando postgress 8.4? Sabes de donde viene el problema de pl/java para 8.4?

    Me da la sensación de que ya es hora de migrar (en realidad, creo que habria que comenzar a hacer updgrades en muchos otros componentes…).

    EDITO: bueno, el link anterior es especifico parao i386; si no es tu caso aca estan otras versiones https://launchpad.net/ubuntu/lucid/+package/postgresql-8.3

    #34918
    Federico Cristina
    Superadministrador

    Buenas,

    Podés descargarte los fuentes de postgre 8.3 y compilarlos, no es una tarea demasiado compleja. Yo lo hice en mi instalación de Ubuntu 10.04 sin mayores inconvenientes (lamentablemente no documenté al respecto). Seguramnete el gmake te pedirá instalar algunas librerías adicionales para compilar correctamente el proyecto, pero no es mucho más que eso.

    Supongo que la otra alternativa es redireccionar la configuración de Origen de Software a fin de que apunte a una distribución anterior de Ubuntu en la que se cuente con Postgre 8.3 (sin embargo, esto no lo probé).

    Suerte!!
    Federico

    #34919

    Fede y Javi, gracias por la data. Voy a probar ambas cosas. Ya había intentando con unos .deb para Debian, pero pinchó mal.

    Javi, respecto al tema de la 8.4, hace poquito leí en éste foro, el hilo de alguien que hizo pruebas sobre Windows y anduvo bien, pero que en Lnx seguía con incompatibilidad. Si es un tema del motor, dudo que podamos hacer algo al respecto. Pero bueno, por lo pronto intentaré hacer andar la 8.3

    Saludos y gracias!

    #34920

    Fede, te acordas en que momento del proceso de compilación se define la estructura de directorios común y silvestre del postgres?

    Pude compilar y hacer andar el motor. Iniciar el servicio y crear bases. Pero no configuré correctamente la estructura de directorios, para que quede algo así como Postgresql/8.3/…
    Entonces, no existen o no doy con los archivos de configuración, ni con el archivo enviroment.

    Igual, si no te acordas no importa, de todas formas tengo que desinstalar y hacer todo de nuevo.

    Saludos!

    #34922

    bueno hice todo de nuevo, y apareció el directorio de instalacion… instale unos paquetes para que el ./configure no pinche.

    apt-get install libreadline5-dev y apt-get install zlib1g-dev

    Saludos!

    #34923
    Federico Cristina
    Superadministrador

    Barbaro!

    Posteriormente no hay que olvidarse de inicializar el Postgres con la base de datos inicial, con algo así como ésto:

    Code:
    /usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data

    Seguramente ya lo hiciste, pero lo dejo en este thread porque es un paso posterior de la compilación e independiente a ésta, lo cual a mí me trajo algún que otro dolor de cabeza.

    Saludos!

Viendo 7 entradas - de la 1 a la 7 (de un total de 7)
  • Debes estar registrado para responder a este debate.