Re:Re:No puedo instalar el pl/java…

Inicio Foros Foro principal Instalación y Configuración No puedo instalar el pl/java… Re:Re:No puedo instalar el pl/java…

#33197
Cristian GrubCristian Grub
Miembro

Hola estoy tratando de instalar pljava en centos 5.3. Ya instale Postgres en su versión 8.2.13 y ya funciona bien, pero cuando trato de instalar el pljava me da el siguiente error:

(estoy introduciendo esto en terminal)

$ psql -d postgres -f install.sql

psql:install.sql:1: ERROR: schema “sqlj” already exists
GRANT
psql:install.sql:6: ERROR: could not load library “/usr/local/pgsql/lib/pljava.so”: libjvm.so: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio
psql:install.sql:8: ERROR: function sqlj.java_call_handler() does not exist
psql:install.sql:12: ERROR: could not load library “/usr/local/pgsql/lib/pljava.so”: libjvm.so: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio
psql:install.sql:14: ERROR: function sqlj.javau_call_handler() does not exist
psql:install.sql:23: NOTICE: CREATE TABLE will create implicit sequence “jar_repository_jarid_seq1” for serial column “jar_repository.jarid”
psql:install.sql:23: ERROR: relation “jar_repository” already exists
GRANT
psql:install.sql:32: NOTICE: CREATE TABLE will create implicit sequence “jar_entry_entryid_seq1” for serial column “jar_entry.entryid”
psql:install.sql:32: ERROR: relation “jar_entry” already exists
GRANT
ALTER TABLE
psql:install.sql:43: ERROR: relation “classpath_entry” already exists
GRANT
psql:install.sql:50: NOTICE: CREATE TABLE will create implicit sequence “typemap_entry_mapid_seq1” for serial column “typemap_entry.mapid”
psql:install.sql:50: ERROR: relation “typemap_entry” already exists
GRANT
psql:install.sql:55: ERROR: language “java” does not exist
psql:install.sql:59: ERROR: language “java” does not exist
psql:install.sql:63: ERROR: language “java” does not exist
psql:install.sql:67: ERROR: language “java” does not exist
psql:install.sql:71: ERROR: language “java” does not exist
psql:install.sql:75: ERROR: language “java” does not exist
psql:install.sql:79: ERROR: language “java” does not exist
psql:install.sql:83: ERROR: language “java” does not exist
psql:install.sql:87: ERROR: language “java” does not exist

Primero que nada quiero saber si la versión de pljava es la correcta para la version de postgresql(8.2.13) y si hay problemas con que centos sea en su version 5.3. GRACIAS!!!!