Re:Re:componentes atributos – error al ejecutar

Inicio Foros Foro principal Ayuda componentes atributos – error al ejecutar Re:Re:componentes atributos – error al ejecutar

#35374
Javier Ader
Participante

Bueno, no se nada del componente, pero ese error que mostras surge porque no esta econtrando un clase. Para que no encuentre una clase, una de dos, o la clase nunca existió (seria medio raro…) o estas corrindo un cliente cuyas librerias no se actualizaron después del upgrade (no se si esta en los pasos de la instalación del componente, pero en algun momento seguro que alguien o algo tiene que disparar el Configurar.exe; ejecútalo por las dudas).
Otras cosas:
-Proba el cliente pesado (tiene que estar en el directorio lib; ClienteLBY.zip; copialo a algún lado y descomprimilo). Mira la fecha de modificación/creación de este zip; tiene que tener la la fecha en que ejecutaste el ultimo Configurar.exe (si no me equivoco, este zip se crea cada vez que se ejecuta ese proceso; adentro van a parar .jar’s que tiene que tener todas las librerías necesarias para que ande el cliente pesado).
-Si te sigue sin andar, subí el cliente pesado a algun lado y pasa el link; es facil ver si existe la clase GenAttSetInstCombinations (si queres chequealo vos mismo; descomprimi los .jars que hay dentro del cliente pesado como si fueran un zip; este te tiene que generar un estructura de directorios como muchos archivos con extensión class; alguno de ellos tiene que ser GenAttSetInstCombinations.class y debería estar bajo un subdirectorio de la forma org/libertya/attributeSet/process). Si esa clase no existe, bueno el cliente pesado se genero de manera incorrecta; si se genero de manera incorrecta debe ser por que el configurar.exe no encontró los .jars necesarios (el jar que originalmente contiene a esta clase) y… si no lo encontró… bueno, ya no se, pero por ahí debería andar la cosa (probablemente sea porque no lo hallo en el subdirectorio “plugings” o como se llame el directorio en el que hay que poner los jars de los plugins)

Si con el cliente pesado te anda, bueno, por el momento deja de usar clientes livianos, mas si tenes algún cliente liviano que lo trajiste desde la versión vieja (acá estoy tocando de oido; pero me da la sensación que el cliente liviano puede cachear clases y en particular .jars en la maquina local; la otra seria vaciar la cache de Java).