Re:Re:componentes atributos – error al ejecutar

Inicio Foros Foro principal Ayuda componentes atributos – error al ejecutar Re:Re:componentes atributos – error al ejecutar

#35373
Carranza Carlos
Participante

Volvimos al problema. Todo lo anterior lo probé en un ambiente de prueba con la base de datos de producción.
Al ir con mi “Solución” a la instalación real, la misma no funcionó.
Entonces volví a la instalación de prueba, generé un artículo y traté de crear las combinaciones y nuevamente dio la falla, la misma que antes :

java.lang.ClassNotFoundException: org.libertya.attributeSet.process.GenAttSetInstCombinations
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:169)
at org.openXpertya.apps.ProcessCtl.startProcess(ProcessCtl.java:520)
at org.openXpertya.apps.ProcessCtl.run(ProcessCtl.java:282)

En otras palabras, no sé porqué funcionó (creía que sí) y ahora volvimos para atrás.

Incluso cree un conjunto de atributos que sólo tuviera el atributo color, lo apliqué y dio la misma falla.

Qué condiciones debe tener el artículo para que no de un error de ejecución (es posible que me falte cargar un dato y por eso no carga?)?

Cómo es el manejo del UPC del articulo y la UPC de la Instancia?