Re:Re:Temas de Interfaz de Usuario

Inicio Foros Foro principal Ayuda Temas de Interfaz de Usuario Re:Re:Temas de Interfaz de Usuario

#33833
Javier AderJavier Ader
Participante

bueno antonio, arranque por tu lado…pero algo raro esta pasando. Esta vez estoy ejecutando el compilar.bat (primero el que esta en tools… despues me di cuenta que tambien hay uno bajo client y pase a ese) desde la maaquina de mi hermana (2 nucleos, 4gb de ram… asi que por ahi no va la cosa) y esta compilando hace como 5 minutos, pero en eclipse desde mi maquina viejita me lo compilo muchísimo más rápido!!! Incluso redirige la saida a un archivo porque siempre tuve la sensación que la salidad por consola bajo Windows ralenta a cualquiera que la use mucho. Ok, no se por donde viene el tema pero me parece que este compilar.bat (cualquiera de ellos) termina disparando la compilación de todo, inclusive de las herramientas externas, cuando me parece que esto no es necesario.
Después comento que paso.

AGREGO: bueno…. es obvio que el problema viene por los paths con espacios (java esta en “Archivos de Programas” por ej). En el archivo de salida (en la consola iba tan rapido que no alcanzaba a leer) se ven cosas como

“de” no se reconoce como un comando interno o externo,
programa o archivo por lotes ejecutable.

repetido varias veces al comienzo y despues entra en bucle infinito al intentar crear el “keytore” desde utils_devVariblesCompilacion.bat (que es lo primero que llama cualquier compilar.bat)…no hay keystore, la creamos, no hay keystore la creamos, y asi forever intercalando un “C:Achivos” comando no reconocido, que es cuando intenta ejecutar el keytool de java…). Así que no se, o reinstalo java en path sin espacio vuelvo a eclipse.
También vi que el variableCompilación.bat inteta crear el C:ServidorOXP… la compilación me iba a pisar mi actual instalación???? si es asi me alegro de que haya fallado jaja (igual eso es solo cosa de cambiar una linea en variablesCompilacion.bat y listo).