Respuesta a: Problema de actualización 19.07 a 21.0

Inicio Foros Foro principal Ayuda Problema de actualización 19.07 a 21.0 Respuesta a: Problema de actualización 19.07 a 21.0

#62349
Federico Cristina
Superadministrador

Buenas!

Probablemente tu instancia no cuenta con la vista ad_plugin_detail_v, y dado que una de las actividades de actualización implica eliminar y regenerar dicha vista, el instalador está informando el error en cuestión.

Tenés dos alternativas para solucionarlo:

1) Crear la vista desde pgAdmin ejecutando la siguiente sentencia SQL:

create view ad_plugin_detail_v as
select 	cv.name, 
	cv.ad_componentobjectuid, 
	pd.version, 
	pd.created, 
	pd.createdby,
	pd.component_export_date as export_date, 
	pd.component_first_changelog as first_changelog,
	pd.component_last_changelog as last_changelog, 
	pd.component_first_changelog_uid as first_changelog_uid, 
	pd.component_last_changelog_uid as last_changelog_uid, 
	pd.component_first_changelog_group_uid as first_changelog_group_uid, 
	pd.component_last_changelog_group_uid as last_changelog_group_uid,
	pd.install_details
from ad_plugin p
inner join ad_plugin_detail pd on p.ad_plugin_id = pd.ad_plugin_id
left join ad_componentversion cv on p.ad_componentversion_id = cv.ad_componentversion_id
order by pd.created asc;  

Esto generará la vista en cuestión y luego el instalador podrá regenerarla.

2) Modificar el archivo preinstall.sql que se encuentra dentro del archivo org.libertya.core.upgrade_19.07_21.0.jar, eliminando o comentando (con dos guiones –) la línea 758:

drop view ad_plugin_detail_v;

Esto omite el drop de la vista que no existe, evitando el error en cuestión.

Slds!
Federico