Re:Re: ClienteLBY

#35754
Javier Ader
Participante

Cliente 9.07??
Bueno, la clase que no encuentra si esta incluida en cliente pesado generado por la version 10.09 (y casi seguro en la 10.03); el archivo OXPXLib.jar termina contendiendo el que esta en tool/lib/log4j.jar; este jar es que el que contiene la clase que no encuentra tu version (org.apache.Log4j.Level).
Mira el libertya.sh, al invocar a java tiene que pasarle como referencia el lib/OXPXLib.jar en algun momento (y tambien el lib/OXP.jar y el lib/JasperReports.jar);

El libertya.sh de donde lo sacaste? Porque al menos en mi sistema no va a parar al cliente pesado (ok, mi sistema es XP, y genera un .exe que basicamente debería hacer lo mismo que el Libertya.sh; no se si bajo sistemas no windows lo genera…. lo deberia generar para ambos, esto es, el Liberya.exe y el Libertya.sh, pero bueno )